Questions tagged [ubuntu]

Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

Filter by
Sorted by
Tagged with
5
votes
5answers
8k views

Unable to install ECW support on lubuntu 14.04

I try unsuccessfully to install the ECW support (mainly to use ECW file in QGIS 2.2). We attempt to follow and adapt the howto provided by makina-corpus. My first supprise was the repository ...
10
votes
3answers
14k views

Installing ECW for QGIS in Ubuntu 12.04?

I have followed various online help guides on how to make ecw for QGIS 1.8 work in Ubuntu 12.04. I had it all working in Ubuntu 10.04 but since migration to 12.04 no such luck. Is there a guide that ...
38
votes
7answers
18k views

How to create svg symbols that have modifiable fill color, stroke color and stroke width?

I want to create some svg symbols for Qgis using Inkscape, those symbols must have attributes as described in the question. For the last two days, I have been experimenting as instructed by Sourcepole ...
58
votes
3answers
72k views

Installing latest QGIS version on Ubuntu? [closed]

I am relatively new to Linux, so can you indicate the exact commands (step-by-step) that I need to type to get the latest QGIS installed on Ubuntu 14.04. I have tried to follow the instructions ...
3
votes
3answers
2k views

Couldn't load SIP Module

After reinstalling QGIS, the desktop program runs but generates the python error "Couldn't load SIP Module Pythin support will be disabled" Because of this error, no plug-ins will load. I found a ...
65
votes
22answers
77k views

Python GDAL package missing header file when installing via pip

I asked this question on Stack Overflow before I realised this site existed. As this site it more appropriate, I'll ask it here too. I'm trying to install gdal from pip pip install gdal inside a ...
24
votes
10answers
34k views

Installing QGIS on Ubuntu?

Has anyone had any luck with getting QGIS working on Ubuntu 12.04? I have tried the stable and unstable versions and with not luck. I also get the following: "Some packages could not be installed. ...
4
votes
4answers
3k views

Installing QGIS on Ubuntu 14.04?

Following the QGIS installation guide I have tried both UbuntuGIS and QGIS stable, but both fail with the error message: The following packages have unmet dependencies: python-qgis : Depends: python-...
2
votes
4answers
3k views

How to get ECW support on QGIS 2.16 - Ubuntu 16.04?

after several attempts I am still not able to enable ECW support on QGIS on Ubuntu Xenial. Before updating to latest version of Ubuntu, solution proposed here worked for me on the same machine, but ...
6
votes
2answers
6k views

Installing QGIS with GRASS plugin on Ubuntu?

I already tried to install QGIS 2.8.3 using the procedure described on: http://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubunt, but grass-plugin do not compare on plugin list! I tried ...
4
votes
2answers
7k views

How to activate GRASS GIS 7 plugin in QGIS 2.8?

Apparently, my linux ubuntu setup of QGIS doesn't contain grass gis, although when I initially installed it last week I added grass gis to the command line. Anyway, I typed in once again and installed ...
2
votes
1answer
922 views

Can't install support for ECW in QGIS 3.6 / 3.4 on Ubuntu 18.04

I've been trying to install support for ECW so I can load them in latest QGIS 3.6 (also tried in QGIS 3.4.4) Having tried the following tutorials: https://wiki.openstreetmap.org/wiki/ECW (gdal 2.2....
16
votes
4answers
1k views

Migrating to Linux from Windows

I am looking at switching over a computer from Windows to Ubuntu. I have been a Windows user all my life and been using GIS for over a decade. I am curious about the migration to Ubuntu. Mostly, ...
3
votes
4answers
2k views

Cannot fix QGIS after upgrade to Ubuntu 13.04 Raring

I have following problem. After upgrade to 13.04 I had problem with PyQGIS mentioned here. I followed almost all advices described there, finally removed QGIS (had 1.8 Lisboa) and added the Ubuntugis ...
2
votes
1answer
582 views

Why does the QgsFeatureIterator crash in my stand alone script?

I'm trying to write a standalone script in qgis 2.10 in ubuntu I have written a script which crashes when I run from bash but works fine from inside the qgis desktop environment. The script is: #!/...
7
votes
3answers
6k views

PostGIS non functional on Ubuntu 14.04

I am unable to create the PostGIS extension on new databases in Ubuntu 14.04: $ psql pg_testing -c "create extension postgis" ERROR: could not load library "/usr/lib/postgresql/9.3/lib/postgis-2.1....
26
votes
6answers
23k views

Install QGIS 2.14 Essen on Ubuntu 16.04 Xenial

I'm having trouble installing QGIS on Xenial. `debian` release When I try using the debian release (i.e. without ubuntugis dependencies) I get the following errors (please note there is no xenial ...
13
votes
4answers
14k views

Repairing broken GDAL and PROJ.4 on Ubuntu?

I solved the library problem, but others remain, only vaguely related to that of PROJ.4 library not loaded. I asked a follow-up question for these. My GDAL package and PROJ.4 library are damaged, ...
6
votes
2answers
4k views

Problem loading vector layer (pyQGIS)

I've installed the qgis on ubuntu 12.04 following the instructions on http://hub.qgis.org/projects/quantum-gis/wiki/Download. I am trying to test the Python API and try to do the follwoing from qgis....
3
votes
2answers
7k views

How to install PostgreSQL 9.2 with PostGIS 2.0 on Ubuntu 11.10 (or higher)?

I have read this question: https://dba.stackexchange.com/questions/25033/install-postgis-v2-for-postgresql-v9-2, but it didn't resolve my problem. I added the PostgreSQL backports PPA and installed ...
9
votes
2answers
2k views

Cannot run Grass algorithms in QGIS 2.18 on Ubuntu 16.04

I have QGIS and GRASS installed through the UbuntuGIS repositories. If I try to execute any GRASS 6 or 7 algorithm I get the following error message: "This algorithm cannot be run :-( It seems that ...
7
votes
1answer
9k views

Geting and installing latest version of QGIS in Ubuntu? [duplicate]

I'd like to get the latest 64-bit dev build of QGIS on my Ubuntu setup. How exactly do I go about it? I assume it's some kind of arcane terminal command.
4
votes
1answer
973 views

QGIS 2.18.5 update breaks on Ubuntu 16.04 [closed]

Concurrent updates to GDAL (to 2.1.3) and QGIS (to 2.18.5) on Linux Mint 18.1 from the Ubuntugis repos breaks QGIS, with a noted dependency for the virtual package gdal-abi-2-1-2 being uninstallable. ...
4
votes
1answer
4k views

Qgis server on Ubuntu Server 14.04: Permission denied

I'm trying to install and configure Qgis Server (2.0.1) on a virtual server with ubuntu 14.04, Apache 2.4.7. After trying to install normally, the server gave me 404 error, so I tried to add ...
3
votes
1answer
686 views

QGIS update from 2.14 to 2.16 failed on Ubuntu 14.04 [closed]

Until yesterday my whole qgis and python-qgis worked fine with version 2.14 under Ubuntu 14.04. After a simple sudo apt-get update and sudo apt-get upgrade qgis failed to update... Several attempts to ...
6
votes
1answer
4k views

Install PostGIS on Ubuntu 12.04

I am trying to install PostGIS on Ubuntu 12.04 and I think everything is installed correctly except for postgresql. I followed this post. I get the following error and nothing I do seems to satisfy ...
6
votes
2answers
3k views

Installing qgis 2.0 and saga 2.1 on ubuntu 13.04

I have been trying to get this working for a few weeks now. I am trying to install QGIS Dufor (2.0.1) and Saga GIS from the Unstable branch of the UbuntuGIS PPA. When I attempt to do this I get the ...
3
votes
1answer
331 views

QGIS 2.10 with ubuntugis dependecies Grass issues Ubuntu 14.04

I saw in Installing QGIS with GRASS plugin on Ubuntu? how to get Qgis 2.10 running from the non ubuntugis repository with grass features but I'm still having problems with getting it to work with the ...
3
votes
3answers
4k views

Install QGIS 3.x on Ubuntu 18.04

I've tried several packages including ubuntugis but none helped. How to install qgis 3.x, more preferably qgis 3.4 lts in Ubuntu? I've added following repos:: sudo add-apt-repository ppa:ubuntugis/...
2
votes
2answers
574 views

How do i install ESRI File GDB API in Ubuntu 16.04 so QGIS 2.8 can see it?

Can someone tell me how to get QGIS 2.8 in Ubuntu to see the ESRI File GDB API? I am trying to install the ESRI File GDB API (https://github.com/Esri/file-geodatabase-api/tree/master/FileGDB_API_1.5) ...
20
votes
8answers
26k views

How can I enable Shapefile GUI Loader in pgadmin3?

I have installed PostgreSQL 9.1 with PostGIS 1.5.3 on Ubuntu 11.10. I also installed pgadmin3 1.14.0-beta1, following this instructions. If I remember correctly, when I installed PostGIS on Windows ...
8
votes
1answer
3k views

gdal2tiles.py gives ERROR 6 about EPSG:900913 on fresh Ubuntu 14.04 install

I have a fresh install of Ubuntu 14.04. I installed gdal with sudo apt-get install gdal-bin python-gdal. After this I have: GDAL 1.10.1 released 2013/08/26. I am trying to tile the weather radar ...
12
votes
2answers
3k views

QGIS fails to load

I installed some python libraries using pip (pandas, scipy, simplekml) and ever since every time I try to load QGIS I get this error: Warning: loading of qgis translation failed [/usr/share/qgis/...
4
votes
2answers
4k views

How to reinstall QGIS from scratch on Ubuntu?

System info: Ubuntu 16.04.3 LTS, kernel 4.10.0-33-generic I was trying to update QGIS using these steps. For some reason, it broke in the process and I'm not able to start it anymore. Executing qgis ...
3
votes
2answers
4k views

Cannot create PostGIS extension with Ubuntu 18.04

I am a few days new to Linux Ubuntu and am in the process of setting up a PostGIS database to use in GeoDjango. I am going to post all my commands that I have done so far these are installed in ...
1
vote
1answer
170 views

QGIS and Ubuntu 'browse' dialogue causing crashing

Below is an image of 'the suspect dialogue' in Ubuntu that when you encounter it in QGIS you are most definitely going to crash the application. http://ow.ly/i/ZGNc/original You find this ...
8
votes
4answers
2k views

Cannot add plugins to QGIS on Ubuntu 11.10 Oneric

I have installed Qgis on ubuntu. it works fine but I am not getting option to add new plugins only option to manage plugins is available. Please help
6
votes
3answers
4k views

Where is QGIS installation path in Ubuntu

I can't find the QGIS installation path in ubuntu 12.10
6
votes
1answer
3k views

Problems installing QGIS 2.2 on Ubuntu 14.04

After major upgrade to 14.04 I tried to purge and reinstall QGIS. Unfortunately I get and error (full listing below) and cannot finish clean installation. Information in the log points errors to ...
5
votes
1answer
2k views

“Couldn't load PyQGIS” Error running QGIS on Ubuntu 14.04

I have installed QGis on Ubuntu 14.04 from the QGis stable repository; it went fine with no errors reported. But when I launch QGis I get this huge window with the following message: Couldn't load ...
5
votes
1answer
2k views

How to re-compile ogrinfo against gdal used by QGIS?

I just solved Repairing broken GDAL and PROJ.4 on Ubuntu? which was blocking use of ogrinfo and ogr2ogr, only to find that these utilities are garbled in one more way: whenever I run any of these, I ...
3
votes
0answers
984 views

QGIS 2.14 fails to install on Ubuntu 14.04

My previously working installation of QGIS 2.14 on Ubuntu 14.04 suddenly failed to start QGIS. I have been trying to reinstall QGIS without success. I have tried several ways to completely uninstall ...
3
votes
3answers
650 views

Installing the development files libqgis-dev in Ubuntu 12.04

I am trying to install development files which include the headers and the libraries for qgis in Ubuntu 12.04. I used Ubuntu software center, synaptic and the terminal and am still getting the same ...
3
votes
2answers
988 views

How to install two versions of QGIS on Ubuntu 12.04?

I would like to run multiple versions of QGIS on Ubuntu 12.04. Can I do that, and how if so?
2
votes
2answers
822 views

libpng problems for QGIS

I'm using ubuntu 18.04 and if I download QGIS 2.18 and I try to run it, I get this: libpng warning: Application jmp_buf size changed Segmentation fault (core dumped) If I try with QGIS 3.2, the ...
12
votes
2answers
10k views

Spatially enabled Postgres database

I am trying to create a spatially enabled PostGIS database. I am following the PostGIS documentation, http://postgis.net/docs/manual-1.5/ch02.html#id2648455. In the short version, i executed, ...
9
votes
2answers
5k views

Install PostGIS and TIGER Data in Ubuntu 12.04

Could someone write a brief albeit dumbed down idiot's guide to installing postgis and loading national Tiger data on ubuntu? I've tried a few guides, namely, http://wiki.bitnami.com/@api/deki/pages/...
12
votes
5answers
25k views

Is ArcGIS available on Ubuntu?

Is ESRI's ArcGIS platform of programs available on Ubuntu? I love open source and if I could I would love to try and migrate to this open source OS.
10
votes
4answers
5k views

Installing QGIS 3 on Ubuntu?

QGIS 3.0 is released. However, in the download page, there does not seem to be an entry (for Ubuntu (16.04) at least): Latest Release 2.18.x Las Palmas (new LTR) https://qgis.org/...
3
votes
4answers
2k views

How compile/install php-mapscript on Ubuntu 16.04

I need to upgrade from Ubuntu 14.04 to 16.04 but php5 is not officially supported on Ubuntu 16. I install php5.5 by ondrej repo https://askubuntu.com/a/756186/483814 but when I try to install php5-...