Questions tagged [ubuntu]

Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

Filter by
Sorted by
Tagged with
0
votes
0answers
12 views

sen2cor L2A_Process not working, returns strange error

I am trying to perform the correction on some sentinel 2 imagery using sen2cor L2A_Process on the 10 m resolution. Script returns some strange error. Below is the full output: Sentinel-2 Level 2A ...
1
vote
0answers
18 views

Script PyQGIS without Interface in Ubuntu

please can you help me? I tried many times to do a script of pyqgis but without interface qgis. I use QGIS 3.6.3 and Ubuntu 18.04, does Somebody know do this?
2
votes
1answer
47 views

Amnesic installation of QGIS 3.4 on Ubuntu 18.04

I installed QGIS 3.4 with the repository https://qgis.org/ubuntu-ltr bionic main on an Ubuntu 18.04 machine. I had some troubles due to the presence of several repositories listed in my file sources....
3
votes
2answers
1k views

Error adding qgis.org repository public key to apt keyring

The old QGIS key ring qgis-2017.gpg.key is expired and generates a warning during apt update today. Following the QGIS instructions, I tried to update the key as follows: wget -O - https://qgis.org/...
1
vote
1answer
68 views

QGIS server installation: Do I need to create a qgis user?

I am following the instructions in the official docs to install QGIS Server (3.8) on my Ubuntu server (18.04). Throughout the docs, a /home/qgis/ folder is mentioned. 12.1.3. Follow Along: HTTP ...
2
votes
1answer
66 views

Getting libpng error for QGIS on Ubuntu 19.04?

So I have already attempted the solutions that were posted here, and I still get the same issue even after reinstalling QGIS: libpng problems for QGIS I keep getting the following error message: ...
0
votes
0answers
52 views

New GDB issues with QGIS 3.8

I just got a new MacBook Pro and installed QGIS 3.8 yesterday. I had several GDBs working on Ubuntu and QGIS 3.4 but that same GDB will not import in 3.8 on the MacBook Pro. They are vector layer ...
1
vote
1answer
112 views

Install QGIS 3.4 with GRASS support in Ubuntu 18.04

I can install QGIS3.X but cannot run a GRASS process. I get the popup: This algorithm cannot be run :-( GRASS 7 can't be found on this system from a shell. Please install it or configure your ...
1
vote
0answers
19 views

GeoServer GWC seeding in 900913 slower than 4326

Using the integrated GeoWebCahce for GeoServer, I am trying to create a tiled cache for a layergroup and having a problem when trying to seed in EPSG:900913. Even after increasing both the minimal and ...
0
votes
0answers
23 views

Install SWAT hydrological model on Ubuntu [duplicate]

I am trying to go back using Ubuntu in my work as hydrologist. Is there any way to install the SWAT model, and in particular QSWAT on Ubuntu?
0
votes
1answer
290 views

Installation of QGIS 3.4.4 on Ubuntu 16.04 fails to install qgis-plugin-grass because of uninstallable grass760 dependency

I have used the instructions here marked Tested 29/06/2018 to install QGIS 3.4.4 on Ubuntu 16.04. While QGIS installs nicely I get an error on installing qgis-plugin-grass. Subsequently the Grass ...
0
votes
2answers
178 views

ERROR 1: NUMPY driver was compiled against GDAL 2.1, but the current library version is 2.2

When running my Python program, the following error came out: ERROR 1: NUMPY driver was compiled against GDAL 2.1, but the current library version is 2.2 What can I do to fix this?
0
votes
0answers
186 views

Installing OSGEO and GDAL in Ubuntu

I'm trying to run a Python program which needs to import from osgeo import gdal, ogr import osgeo.ogr, osgeo.osr from osgeo.gdalconst import * But when I run it outputs Traceback (most recent call ...
5
votes
1answer
790 views

Can't install QGIS 3.x on Ubuntu 18.04

In the fall of 2018, I successfully installed QGIS 3.x on my old Xubuntu 18.04 laptop (it keeps updating, and now it is 3.6). A couple of months ago I had to move to another laptop (again under ...
0
votes
1answer
199 views

Installing PostGIS after PostgreSQL Ubuntu 18.04

sudo apt-get install postgresql-9.5-postgis-2.5 returns a series of errors: The following packages have unmet dependencies: postgresql-9.5-postgis-2.5 : Depends: libgdal1i (>= 1.9.0) but it is ...
1
vote
1answer
213 views

rgdal installation error: How to set GDAL_DATA directory?

I've long had GDAL, proj, etc. installed and working fine for various other related software (e.g., QGIS). Unfortunately, every time R gets updated it tends to lose links to previously installed R ...
0
votes
0answers
17 views

Newly added layers to QGIS 2.18 will not display in the print composer

I have an existing QGIS project that until today was just fine. I added a new shapefile to the project but these new data fail to display in the print composer. All other existing data in the ...
0
votes
1answer
280 views

PostGIS cannot create extention:ERROR: cache lookup failed for function 1

When trying to create PostGIS extension I am getting this error: ERROR: cache lookup failed for function 1 I am running PostgreSQL 11 on Ubuntu 16.04. I have installed PostGIS and PostGIS scripts. ...
0
votes
1answer
48 views

Configuring MapServer on Ubuntu with Apache

I am using Ubuntu 18.10 /x64 / Apache2. I wish to install MapServer on my system. The packages can be obtained from this place: https://launchpad.net/ubuntu/+source/mapserver/7.2.0-5/+build/15292173 ...
1
vote
1answer
236 views

QGIS Compiling 3.6.0 Troubleshooting about PyQt5, SIP, Qscintilla on Ubuntu 18.04 LTS

I work on UBUNTU 18.04 LTS/bionic, I am trying to compile QGIS 3.6.0, for an upgrade from QGIS 3.2. 0. I am facing the same trouble as several people the release compatibility between SIP and PyQT5 ...
1
vote
1answer
51 views

Mapserver weird output of REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1

Once I use REQUEST=GetCapabilities&SERVICE=WMS&VERSION=1.1.1 in my browser with the mapserv I get the following: $ cat ~/Downloads/ms ELF>�@@!@8 @@@@��888�� �� � �� �� � TTTDDP�tdLLQ�...
2
votes
0answers
224 views

QGIS 3.6 menu bar missing [closed]

I am running Ubuntu 18.04 with the XFCE interface and QGIS v3.6. When I start QGIS the menu bar at the top of the window is missing, and I can't find any way to bring it back. I found some solutions ...
1
vote
0answers
107 views

SAGA 2.3.1 makes QGIS 2.18 crash on Ubuntu 18.04 [closed]

On Ubuntu 18.04, using packages provided by universe repos QGIS 2.18.17+dfsg-1 SAGA 2.3.1+dfsg-3build7 When starting any SAGA algorithm, QGIS crashes with a "Segmentation fault" error message. We ...
2
votes
1answer
928 views

Can't install support for ECW in QGIS 3.6 / 3.4 on Ubuntu 18.04

I've been trying to install support for ECW so I can load them in latest QGIS 3.6 (also tried in QGIS 3.4.4) Having tried the following tutorials: https://wiki.openstreetmap.org/wiki/ECW (gdal 2.2....
1
vote
1answer
52 views

OpenDroneMap returns error on merging depthmaps?

I am doing a reconstruction on 424 Parrot Sequoia RGB images using OpenDroneMap. The reconstruction runs for about 2 hours then throws the error shown below. I have successfully done several ...
1
vote
0answers
22 views

Unable to use PyQGIS since python is unable to import qgis libraries

I am using Ubuntu 18.04. I have installed QGIS 3.4.4 Madeira on my laptop. I am learning PyQGIS. I have found these lines of code that I have executed in my terminal but I get a traceback saying that ...
1
vote
0answers
143 views

Cannot install QGIS 3 on Ubuntu 18.04 (From ubuntu repo. Not ubuntugis-unstable ) [duplicate]

When I want to install QGIS latest ver 3.3.4 to ubuntu 18.04 it rises error bellow : Setting up qgis-providers (1:3.4.4+28bionic) ... /usr/lib/qgis/crssync: error while loading shared libraries: ...
1
vote
1answer
153 views

Unable to install QGIS on Ubuntu 16.04

I am trying to install QGIS (any version) on Ubuntu 16.04 and Python 2.7 or Python 3.7.2 I run the sudo apt-get install qgis python-qgis qgis-plugin-grass saga and I get : Reading state information....
3
votes
3answers
4k views

Install QGIS 3.x on Ubuntu 18.04

I've tried several packages including ubuntugis but none helped. How to install qgis 3.x, more preferably qgis 3.4 lts in Ubuntu? I've added following repos:: sudo add-apt-repository ppa:ubuntugis/...
2
votes
0answers
112 views

How to tune the performance of Nominatim Reverse Geocoding Application

Running the query directly to the PostgreSQL takes 3-8ms. The PostgreSQL can handle 500 concurrent connections. The Apache server is running on 8 core CPUs. Analyzing the Apache access logs: There are ...
0
votes
1answer
114 views

Install osgeo live package in existing Ubuntu?

I am using Ubuntu. In my secondary computer I use Lubuntu based OSGEO-LIVE 12.0. OSGEO-LIVE is a great software when it comes to any GIS application and reduces tedious work of individual package ...
1
vote
0answers
169 views

PostGIS install Ubuntu: GEOS problems

Using apt-get install, I've added the following packages: postgis/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 amd64 [installed] postgis-doc/bionic-pgdg,now 2.5.1+dfsg-1.pgdg18.04+1 all [installed,...
0
votes
0answers
21 views

Zoo-Kernel error in compile

I am trying to install zoo-project on Ubuntu 18.04 based on Zoo-Project doc when I want to compile ZOO-Kernel with makecommand, I receive below error: gcc -shared -I/usr/include/gdal -Wl,-soname,...
1
vote
1answer
320 views

Is it possible to install zoo-project in Ubuntu 18.04?

I want to install zoo-project in Ubuntu 18.04 (bionic), but it seems there aren't any programs to do that, for example I have a problem with zoo-kernel install because there is not "ibmozjs185-dev" ...
5
votes
3answers
1k views

QGIS installation vanished! Re-installation attempts produce dependency-errors

So, I am using Ubuntu 18.04.1 LTS and use Qgis 3.4 for GIS analysis. I had a week long pause using QGIS for about a week, and it was quite an unhappy surprise to find out this morning that the whole ...
0
votes
1answer
190 views

How to downgrade from ubuntugis-unstable to ubuntugis-stable

I have some problems with gdal and I would like to downgrade all of my ubuntugis related libraries on Ubuntu 16.04 again to the stable libraries. How can I do that?
3
votes
0answers
170 views

QGIS 3 downgrade on Ubuntu

I updated to QGIS 3.4 on Ubuntu, but there are some functions that are not working so I want to downgrade. Therefore, I have several questions: How to downgrade or reinstall to some older version ...
1
vote
0answers
117 views

Error on simple standalone script

I want to develop a PyQGIS standalone script only using Ubuntu terminal, so to start I use: from qgis.core import * QgsApplication.setPrefixPath("/path/to/qgis/installation", True) qgs = ...
2
votes
2answers
126 views

GIS software that can work only on Ubuntu Terminal? [closed]

Recently, I tried to open a QGIS project on Ubuntu, but I can only use Ubuntu's terminal for that which gives me the following error: QGIS starting in non-interactive mode not supported. You are ...
0
votes
2answers
257 views

Setting GeoServer data directory location?

I want to run GeoServer 2.14 with Jetty on a Ubuntu 18.04. I copied the war-file in the webapps folder and GeoServer is responding. Unfortunately I can not set the data directory location as ...
2
votes
0answers
25 views

QGIS does not remember paths to previous projects after restarting computer

I am running QGIS 2.18 on Ubuntu 16.02. After turning on my computer and opening QGIS I see that QGIS will not remember the paths to previously opened projects. I can see a thumbnail of these ...
1
vote
0answers
66 views

Can't select vector layer QGIS Zonal Statistics

I'm running QGIS 3.4.0 on Ubuntu 18.04.1. I have a raster layer and a vector layer from a .shp file in the same CRS. When The window pops up for zonal statistics, I can select my raster layer but ...
1
vote
0answers
219 views

QGIS 3.2 installation error on Ubuntu 16

I am installing QGIS, I added the repository and cleaned my machine of any QGIS Packages, I tried removing and reinstalling qgis-providers but the same issue occurred again (see error-message): ...
0
votes
0answers
186 views

Alternative of Web App Builder

I'm currently using: QGIS 3.2, OS: Linux (Ubuntu) The Boundless plugin i.e. QGIS web app builder isn't supported on QGIS 3 version I guess. I tried installing it through the zip file method but ...
3
votes
2answers
767 views

Linux Ubuntu 18.04 QGIS shuts down with no errors

Ubuntu 18.04, using this guide to install qgis on the machine. https://linuxhint.com/install-qgis3-geospatial-ubuntu/ sudo apt-get update sudo apt-get install qgis python-qgis qgis-plugin-grass I ...
1
vote
2answers
313 views

PostGIS 2.5 error while compiling from source on Ubuntu Server 18.04

I'm compiling PostGIS 2.5 from source on Ubuntu Server 18.04 The server had no internet connection due to client requirements, so I've been following PostGIS 2.5.1dev Manual, 2.4. Compiling and ...
1
vote
1answer
383 views

Error while installing QGIS with conda

I'm trying to install QGIS through conda $conda install -c conda-forge qgis but got the following error Solving environment: failed UnsatisfiableError: The following specifications were found to be ...
0
votes
0answers
672 views

Python bindings for PCL (Point Cloud Library)

I am curently searching for some Python 3.x bindings for PCL on Ubuntu (16.04). The ones I found are: pclpy: pip cannot find it. python-pcl: I have tried to install it but I always end up on ...
1
vote
0answers
48 views

Landsat util error when downloading data

I am having trouble when trying to download data using Landsat util. Using the following command: landsat download LC81710792016253LGN01 I get the following issue: landsat download ...
1
vote
0answers
58 views

QGIS won't save on to SAMBA on Ubuntu

I have a couple of QGIS applications (one 3.2.2-Bonn and one 2.18.9 Las Palmas) running on Ubuntu boxes (both 18.04.1 LTS). Files are loaded from a SAMBA file share and load fine. But when I try to ...