Questions tagged [ubuntugis]

A GIS repository for Ubuntu Linux operating systems. It is an external repository (PPA) that can be added to sources.list. It contains many FOSS GIS packages including all dependencies. Users should check the UbuntuGIS website for a list of software and tools included in the package at any given time.

Filter by
Sorted by
Tagged with
0
votes
1answer
23 views

Problem adding add-apt-repository ppa:ubuntugis/ppa

Since upgrading my Ubuntu to focal (Ubuntu 20.04.1 LTS) I get the following error every time that I update/upgrade my system: Err:8 http://ppa.launchpad.net/ubuntugis/ppa/ubuntu focal Release 404 ...
0
votes
0answers
32 views

Update from QGIS 3.10 to 3.14 on Ubuntu with ubuntugis-unstable

I just formatted my laptop and wanted to make a fresh install of all the spatial stuff. I thought I'd use the ubuntugis-unstable ppa. But apparently this still comes with QGIS 3.10. So I wondered what ...
1
vote
1answer
224 views

Steps for installing new GDAL version for Python in Ubuntu 18.04

If I'm installing the GDAL stock version from Ubuntu 18.04 then the installed version is 2.2 and I need at least 3.0.4 to better handle Sentinel 2 data. Is there a way to update GDAL to version 3.1.0?...
5
votes
1answer
157 views

ZSTD support for GDAL GeoTIFFs with UbuntuGIS

I have some GeoTIFFs that are compressed with the ZSTD standard. I'm trying to serve those on a VM that has UbuntuGIS installed via the UbuntuGIS PPA: https://launchpad.net/~ubuntugis/+archive/...
0
votes
0answers
31 views

QGIS 2.x installing Ubuntu 18.04

I can't find any installation repo for QGIS 2.x. Last week I was able to install QGIS 2 then I wanted to try QGIS 3.x. However I encountered many problem related with netCDF. Ergo, wanted to install ...
3
votes
1answer
150 views

SAGA library is not visible in Processing Toolbox

The screenshot of Options > Processing I have SAGA plugin activated in my QGIS 3.8 on a Ubuntu 18 LTS machine. However, it does not show up in my Processing Toolbox. Could anyone help me solve ...
0
votes
1answer
2k views

GDAL 2.4.2 from UbuntuGIS unstable broken because of missing libogdi.so.3.2? [closed]

After an unthoughtful apt-get update today, GDAL no longer works on my Ubuntu Machine (bionic) because libogdi.so.3.2 is missing: daniel@gin-nuest:~$ gdalinfo gdalinfo: error while loading shared ...
2
votes
0answers
94 views

QGIS Server Plugin Loading Problem: 'unexpected type 'sip.wrappertype'

I'm using 3.6 qgis on the Ubuntu 18.04 server. I made a plugin for limiting requests on our WMS server. I'm having troubles loading the plugin I get always error: Traceback (most recent call ...
0
votes
1answer
816 views

Installation of QGIS 3.4.4 on Ubuntu 16.04 fails to install qgis-plugin-grass because of uninstallable grass760 dependency

I have used the instructions here marked Tested 29/06/2018 to install QGIS 3.4.4 on Ubuntu 16.04. While QGIS installs nicely I get an error on installing qgis-plugin-grass. Subsequently the Grass ...
0
votes
0answers
1k views

Installing OSGEO and GDAL in Ubuntu

I'm trying to run a Python program which needs to import from osgeo import gdal, ogr import osgeo.ogr, osgeo.osr from osgeo.gdalconst import * But when I run it outputs Traceback (most recent call ...
7
votes
6answers
9k views

Install QGIS 3.x on Ubuntu 18.04

I've tried several packages including ubuntugis but none helped. How to install qgis 3.x, more preferably qgis 3.4 lts in Ubuntu? I've added following repos:: sudo add-apt-repository ppa:ubuntugis/...
0
votes
1answer
525 views

How to downgrade from ubuntugis-unstable to ubuntugis-stable

I have some problems with gdal and I would like to downgrade all of my ubuntugis related libraries on Ubuntu 16.04 again to the stable libraries. How can I do that?
2
votes
2answers
228 views

GIS software that can work only on Ubuntu Terminal? [closed]

Recently, I tried to open a QGIS project on Ubuntu, but I can only use Ubuntu's terminal for that which gives me the following error: QGIS starting in non-interactive mode not supported. You are ...
2
votes
1answer
785 views

Can't seem to get QGIS 3.2 installed in Linux Mint - Only 2.18

I'm at the end of my rope here. I'm trying to install QGIS 3.2 on my computer running Linux Mint 18.3 and I've gone through installing the unstable PPA and updating and upgrading half a dozen times ...
1
vote
1answer
280 views

compile gdal with ESRI FileGDB_API Ubuntu

I'm trying to build GDAL on Ubuntu 16.04 with ESRI FileGDB_API driver support. I've followed the instructions here: https://trac.osgeo.org/gdal/wiki/FileGDB and have attempted to pass the location of ...
8
votes
1answer
702 views

QGIS Server doesn't render any fonts on Ubuntu 16.04

I just updated qgis-server package to latest 3.2.x from Ubuntugis repository (ubuntugis-unstable) and everything works fine - but font rendering. All labels on tiles, legend and print templates show ...
4
votes
0answers
2k views

Install QGIS 3 and QGIS 2.0 Ubuntu 18.04 [duplicate]

I have successfully installed QGIS-3 on my ubuntu 18.04. I want to install QGIS-2 as well along with QGSI-3. How can i install QGIS-2.18 as well. So that QGIS 2 and QGIS 3 both would be running on my ...
4
votes
3answers
4k views

Error when installing QGIS 2.x and 3.0 on Ubuntu 16.04 and Ubuntu 17.10

I am attempting to install QGIS 3.0 on Ubuntu 16.04 and am failing. Outlined below are the steps I've taken to install and troubleshoot this failure. If anyone has any tips on how to troubleshoot this ...
0
votes
1answer
68 views

Import Files failed with cartoDB installed in Ubuntu 14.04 LTS

I have successully installed and configured CartoDB in Ubuntu 14.04 LTS VM and could also view the main page of CartoDB interface and login into my development account. But when I try to import any ...
3
votes
1answer
3k views

Ubuntu16.10: install GDAL on Python3.6

I am on Ubuntu16.10. I would like to install GDAL on Python3.6. I have installed Python3.6 with apt-get install python3.6. I am installing GDAL with: apt-get install -y software-properties-common ...
1
vote
0answers
175 views

QGIS is not starting

My QGIS Installation is not loading after startup, cause of an error thrown. I have looked in similiar topics like QGIS fails to load and tried all of the options available. I changed to scipy 0.17 ...
1
vote
0answers
390 views

Difference between debian and ubuntugis repositories?

I just spent some time struggling to upgrade to QGIS 2.18. I originally had these lines in my /etc/apt/sources.list: deb http://qgis.org/ubuntugis xenial main deb-src http://qgis.org/ubuntugis ...
2
votes
3answers
482 views

Use full QGIS functionality on Server with GUI

I would like to know if there is an easy and efficient way to use the full QGIS desktop experience on a server. Currently I installed QGIS desktop on an Ubuntu Server and I am able to open the ...
2
votes
2answers
3k views

Install QGIS Ubuntugis on Ubuntu 17.10

can't install qgis as per qgis download page. at command line: sudo apt-get install qgis python-qgis qgis-plugin-grass getting unmet dependencies: The following packages have unmet dependencies: ...
1
vote
1answer
620 views

undefined symbol: OGR_F_SetFieldNull when installing qgis

I tried to re-install qgis on Ubuntu 16.04 LTS (xenial) using the ubuntugis repository (http://qgis.org/ubuntugis) but I get the following error messages which I cannot resolve: Setting up qgis-...
2
votes
2answers
1k views

Handle two versions of GDAL

I want to use two different GDAL versions on my Ubuntu 16.04. I installed GDAL via the UbuntuGIS ppa and via anaconda. My GDAL for python works fine, but when I want to use gdal_translate via the ...
4
votes
2answers
1k views

Can not install packages from UbuntuGIS

I recently changed my OS to Xubuntu 16.04. Now i try to install GDAL to use it via shell and QGIS. I followed the steps from the official UbuntuGIS website (https://launchpad.net/~ubuntugis/+archive/...
0
votes
0answers
350 views

Error while compiling gdal 1.9.2 in Ubuntu16.04

I am trying to compile and build gdal 1.9.2 in Ubuntu 16.04.3. I am doing the below steps sudo wget http://download.osgeo.org/gdal/gdal192.zip unzip gdal192.zip -d gdal cd gdal cd gdal-1.9.2/ sudo ./...
1
vote
1answer
3k views

How to install older GDAL v1.11 on Ubuntu 16.04 instead of v2.1.3

I have another question going on this forum regarding GDAL 2.1 ogrinfo not working at Trying to get GDAL 2.x to work, but ogrinfo reports ERROR 3: and ERROR 4: and "Failed to open table res_t48....
1
vote
1answer
256 views

Install Server in UBUNTU Desktop 17.04 [closed]

My last question here was " Install webpage Admin in Ubuntu GIS (Server) " but i´m trying to do something new while i´m waiting for the possible answers: I have Windows 10 in PC (With QGIS 2.18.7 and ...
0
votes
0answers
153 views

Geoserver mvn install success, maven eclipse build success but Eclipse fails to run project

I am able to download geoserver source code , build it with maven , create maven eclipse project but when i load the project from /src in the eclipse it does not run. after checking build path i found ...
3
votes
1answer
2k views

Can QGIS be installed on Ubuntu 17.04 Zesty?

I cannot find a repository for QGIS (2.18 or LTR 2.14) compatible with the latest Ubuntu distro (17.04) in any of the PPA's listed in the installer docs. Do I have to wait for a 17.04 supported ...
4
votes
1answer
993 views

QGIS 2.18.5 update breaks on Ubuntu 16.04 [closed]

Concurrent updates to GDAL (to 2.1.3) and QGIS (to 2.18.5) on Linux Mint 18.1 from the Ubuntugis repos breaks QGIS, with a noted dependency for the virtual package gdal-abi-2-1-2 being uninstallable. ...
12
votes
2answers
1k views

QGIS removed after updating to 2.18.5 on ubuntu

After updating to QGIS 2.18.5 using ubuntugis ppa my QGIS 2.18.4 installation was removed and I get an error about unmet dependencies when I try to install QGIS at the terminal: The following ...
3
votes
2answers
556 views

Unable to open GRASS GIS from command line

I am trying to start GRASS GIS from the command line in ubuntu 14.04 and i keep getting the following error: user@computer:~$ grass Cleaning up temporary files... Traceback (most recent call last): ...
5
votes
1answer
3k views

QGIS installation fails under Ubuntu 16.04

I decided yesterday to upgrate QGIS from 2.16 to 2.18. This turned out to be a stupid idea, because the following happened: After removing, purging and autoremoving qgis, python-gis and grass I ...
1
vote
1answer
129 views

Can't fetch addons in GRASS GIS 7.0.4 on Ubuntu 14.04

I'm setting up a new install of GRASS 7.0.4 (from Ubuntugis) on Ubuntu 14.04 and having trouble installing addons. Specifically, when I try to "fetch and install extensions from GRASS Addons," I ...
0
votes
1answer
154 views

Installing spatialite-gui using ubuntugis

I am unable to install spatialite-gui using the ubuntugis unstable ppa. There appears to be a conflict between the GEOs libraries required by QGIS, which I installed first successfully (GEOS 3.5.0 ...
5
votes
3answers
356 views

Qgis globe plugin (2.16) missing on Ubuntu 14.04

I just upgraded from Qgis 2.14 to 2.16 and I can't get the Globe plugin to work. Apparently, under Ubuntu it is necessary to install it separately. But in the Ubuntugis repository, only version 2.14 ...
6
votes
1answer
3k views

Where to find a version of libgeos-c1 compatible with libgeos-3.5.0?

This morning a number of Python scripts stopped functioning after a system upgrade. libgdal is no longer available, resulting in the following exception: ImportError: libgdal.so.1: cannot open shared ...
1
vote
0answers
331 views

ogr2ogr not running on Ubuntu 15.10

I'm trying to convert an osm.pbf file to a spatialite db but I can't get ogr2ogr to run. I have qgis 2.14.2 and ubuntu 15.10. I've reinstalled gdal-bin and I'm getting the following message from the ...
0
votes
3answers
3k views

PostGIS broken after Ubuntu 16.04 upgrade

I upgraded Ubuntu from 15.01 to 16.04 and PostGIS is broken. Below are the errors: psql (9.5.2) Type "help" for help. osm=# select version(); version ------...
1
vote
0answers
58 views

Error while creating plugin using plugin builder in Ubuntu 15.04

I am building a QGIS plugin using qgis plugin builder 2.10.1. I am using Ubuntu 15.04. I had selected (/usr/share/qgis/python/plugins) path for the plugin to store in plugin builder, Its raising an ...
4
votes
2answers
257 views

GRASS r.in.lidar tool generates incomplete rasters

I have been trying to import a huge LIDAR file (10.5) Gb to GRASS GIS using r.in.lidar. It does the task, but only for part of the image, as shown below: Canopy Height Model (CHM) generated with ...
4
votes
1answer
793 views

Pre-compiled GIS software for ARM architectures

I would like to install some GIS software on my ARM laptop; QGis in particular would be useful. On x86 architectures I install packages from the much useful UbuntuGIS repository. However, this ...
0
votes
0answers
487 views

Unable to install pgrouting for postgres 9.3.5/postgis 2.1.7

I am running postgres 9.3.5 and postgis 2.1.7 on Ubuntu Server 14.10. I am trying to install pgrouting, but having no luck. 1) I tried the following based in the official workshop documentation: ...
3
votes
1answer
4k views

How to install the latest PostGIS in Ubuntu

I am wondering how can I install the latest PostGIS 2.2 (testing) from the Debian GIS project here: https://launchpad.net/ubuntu/+source/postgis/2.2.0+dfsg-3 I tried apt-get install -s postgis after ...
1
vote
1answer
2k views

Install latest Osmosis version on Ubuntu

I am using Ubuntu 14.04 and I would like to know the easiest way to install the latest (stable) version of Osmosis, which is 0.44. I ran sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable sudo ...
2
votes
1answer
730 views

How to install OSM .pbf support in GDAL on Debian?

I'm trying to use Anita Graser's post on loading OSM data from .PBF files into a SQLite .db file using ogr2ogr but it stopped working. I'm trying to run the following command: ogr2ogr -f "SQLite&...
3
votes
1answer
335 views

QGIS 2.10 with ubuntugis dependecies Grass issues Ubuntu 14.04

I saw in Installing QGIS with GRASS plugin on Ubuntu? how to get Qgis 2.10 running from the non ubuntugis repository with grass features but I'm still having problems with getting it to work with the ...