Questions tagged [ubuntugis]

A GIS repository for Ubuntu Linux operating systems. It is an external repository (PPA) that can be added to sources.list. It contains many FOSS GIS packages including all dependencies. Users should check the UbuntuGIS website for a list of software and tools included in the package at any given time.

11 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2
votes
0answers
24 views

QGIS Server Plugin Loading Problem: 'unexpected type 'sip.wrappertype'

I'm using 3.6 qgis on the Ubuntu 18.04 server. I made a plugin for limiting requests on our WMS server. I'm having troubles loading the plugin I get always error: Traceback (most recent call ...
1
vote
1answer
157 views

compile gdal with ESRI FileGDB_API Ubuntu

I'm trying to build GDAL on Ubuntu 16.04 with ESRI FileGDB_API driver support. I've followed the instructions here: https://trac.osgeo.org/gdal/wiki/FileGDB and have attempted to pass the location of ...
1
vote
0answers
145 views

QGIS is not starting

My QGIS Installation is not loading after startup, cause of an error thrown. I have looked in similiar topics like QGIS fails to load and tried all of the options available. I changed to scipy 0.17 ...
1
vote
0answers
302 views

Difference between debian and ubuntugis repositories?

I just spent some time struggling to upgrade to QGIS 2.18. I originally had these lines in my /etc/apt/sources.list: deb http://qgis.org/ubuntugis xenial main deb-src http://qgis.org/ubuntugis ...
1
vote
0answers
283 views

ogr2ogr not running on Ubuntu 15.10

I'm trying to convert an osm.pbf file to a spatialite db but I can't get ogr2ogr to run. I have qgis 2.14.2 and ubuntu 15.10. I've reinstalled gdal-bin and I'm getting the following message from the ...
1
vote
0answers
57 views

Error while creating plugin using plugin builder in Ubuntu 15.04

I am building a QGIS plugin using qgis plugin builder 2.10.1. I am using Ubuntu 15.04. I had selected (/usr/share/qgis/python/plugins) path for the plugin to store in plugin builder, Its raising an ...
0
votes
1answer
182 views

Installation of QGIS 3.4.4 on Ubuntu 16.04 fails to install qgis-plugin-grass because of uninstallable grass760 dependency

I have used the instructions here marked Tested 29/06/2018 to install QGIS 3.4.4 on Ubuntu 16.04. While QGIS installs nicely I get an error on installing qgis-plugin-grass. Subsequently the Grass ...
0
votes
0answers
80 views

Installing OSGEO and GDAL in Ubuntu

I'm trying to run a Python program which needs to import from osgeo import gdal, ogr import osgeo.ogr, osgeo.osr from osgeo.gdalconst import * But when I run it outputs Traceback (most recent call ...
0
votes
0answers
269 views

Error while compiling gdal 1.9.2 in Ubuntu16.04

I am trying to compile and build gdal 1.9.2 in Ubuntu 16.04.3. I am doing the below steps sudo wget http://download.osgeo.org/gdal/gdal192.zip unzip gdal192.zip -d gdal cd gdal cd gdal-1.9.2/ sudo ./...
0
votes
0answers
133 views

Geoserver mvn install success, maven eclipse build success but Eclipse fails to run project

I am able to download geoserver source code , build it with maven , create maven eclipse project but when i load the project from /src in the eclipse it does not run. after checking build path i found ...
0
votes
0answers
414 views

Unable to install pgrouting for postgres 9.3.5/postgis 2.1.7

I am running postgres 9.3.5 and postgis 2.1.7 on Ubuntu Server 14.10. I am trying to install pgrouting, but having no luck. 1) I tried the following based in the official workshop documentation: ...