Questions tagged [unicodeencodeerror]

UnicodeEncodeError, is a built-in exception for Python which is raised when a unicode-related encoding or decoding error occurs.

Filter by
Sorted by
Tagged with
0 votes
0 answers
33 views

UnicodeEncodeError while executing Python code on QGIS 2.6.1

I have installed the plugin QSWAT and created a new project, and what is happening now is the error below. What can be the problem? I've already tried to install different versions of Python and ...
Ewa's user avatar
  • 9
1 vote
1 answer
778 views

Error message when loading Geopandas package

I downloaded the latest version of Anaconda and installed Geopandas through the navigator. When I import the package the following error message is displayed: --------------------------------------...
Oalvinegro's user avatar
0 votes
0 answers
356 views

New QGIS 3.16 error - UnicodeEncodeError: 'ascii' codec can't encode character '\xa9'

For some reason this error now occurs when I open a project in QGIS 3.16. The best I can find online is that the folder path referenced in the error should not contain spaces. Unfortunately it is not ...
Sean's user avatar
  • 29
0 votes
0 answers
77 views

Need to calculate field with special characters with ArcPy getting UnicodeEncodeError

I wrote a script in ArcPy and it attributes the features in a shapefile with the name of the municipality it's located in but some of the municipalities have special characters, Conceição do Araguaia ...
SpookyDLX's user avatar
  • 111
1 vote
2 answers
396 views

Saving layer files and ignoring special characters using ArcPy

I'm trying to save all layers in my ArcMap mxd as .lyr files using the script below. However, I'm getting an error because some group layer names contain special characters (e.g. © : * ) and cannot ...
Anneka's user avatar
  • 103
0 votes
1 answer
140 views

selection by location with search cursor

import arcpy arcpy.env.overwriteOutput = True points = r'C:\Users\Temitope\PycharmProjects\Scripts\DATA\ne_10m_populated_places_simple.shp' countries = r'C:\Users\Temitope\PycharmProjects\Scripts\...
temitope 's user avatar
1 vote
0 answers
94 views

UnicodeEncodeError when creating Grass location on Windows

i´d tried to create a new location, but i have this in my console, iím learning to use grass gis, so can you help me? SIG\Archivos Grass\newLocation> no disponible Iniciando GRASS GIS... ERROR:...
Sol Bravo's user avatar
2 votes
1 answer
426 views

GRASS 7.2.0 doesn't start on PC

when I want to start the program a black window opens and show me the next message: Traceback (most recent call last): File "C:\PROGRA~1\QGIS2~1.18\apps\grass\grass-7.2.0\etc\grass72.py", line 1971,...
Andrés's user avatar
  • 23
4 votes
2 answers
790 views

QGIS python error using qgis2leaf and qgis2web

I'm trying to export a project using qgis2leaf and this error appears: An error has occurred while executing Python code: Traceback (most recent call last): File "C:/Users/grego/.qgis2/python/...
Bandidot's user avatar
2 votes
2 answers
2k views

Python Error in QGIS

I got this error message when I tried to perfoming a spatial join. An error has occured while executing Python code : Traceback (most recent call last): File "C:/Users/Laurent/.qgis2/python/plugins\...
François's user avatar
4 votes
1 answer
4k views

Python encoding error in ArcPy

I am writing a JSON file, as string input, using python, into a .json file in the file system. However I am getting the following error sometimes and I don't know why. Any ideas? UnicodeEncodeError:...
Smalis's user avatar
  • 776
2 votes
0 answers
1k views

Cause of Field Calculator UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 5: ordinal not in range(128)? [closed]

def Befahrung(value1,value2): if value1 is ' ': return ' ' else: return "G:\\Example\\" + str(value1) + "\\File_" + str(value2) + ".pdf" I try to create a field with a hyperlink. It works ...
GEOGEO's user avatar
  • 75
10 votes
3 answers
10k views

Replacing non-English characters in attribute tables using ArcPy and Python?

I have a few shapefiles where some of the attributes contain the non-English characters ÅÄÖ. Since some queries doesn't work with these characters (specifically ChangeDetector), I tried to change them ...
Martin's user avatar
  • 4,928
4 votes
1 answer
2k views

Getting unicode encode error in ArcPy/Python script?

When I am running a script (it checks to which database a mxd is connected) I get the following error: return codecs.charmap_encode(input,errors,encoding_table) UnicodeEncodeError: 'charmap' codec ...
Trashken's user avatar
  • 167