Questions tagged [utf-8]

UTF-8 is a character encoding capable of encoding all possible characters, or code points, in Unicode.

Filter by
Sorted by
Tagged with
1 vote
1 answer
105 views

Error accents and special characters

I am a master's student in Ecology and Environment in Portugal. It's been a few months since I had my first contact with QGIS. When using a shapefile, in the attribute table, I select by expression, ...
Sandy Morgado's user avatar
0 votes
1 answer
36 views

QGIS not showing Tigrinya language

I struggle to display Tigrinya language in QGIS. It is supposed to show with UTF-8 encoding. But the letters are not shown, just white spaces. I went through many other encodings, but coulnd't find ...
Andreas's user avatar
  • 73
1 vote
1 answer
209 views

PostGIS import error

I need to import some shapefiles into a database. PostGIS has successfully imported several small files. But an error occurred with large files. It shows this error: "Unable to convert data ...
Sergey47's user avatar
0 votes
1 answer
55 views

Osmosis merge UTF-8 encoding issue

I am trying to merge together two .osm XML files using Osmosis from CLI. In the XML files there is some public transport data (like bus stops) and some of them have an apostrophe (') in their name (as ...
Gabboxl's user avatar
1 vote
1 answer
113 views

Geoserver java.IOExceptionInvalid value for parameter (possible utf-8 issue)

i m trying to query a view using parameters in Greek SELECT [OBJECTID] ,[Shape] ,[SubStore] ,[StoreCode] ,[subStore] FROM [****].[dbo].[GSRV_POLYGONS] where [StoreCode]>='%StoreCodemin%' ...
sotokan80's user avatar
2 votes
0 answers
907 views

Keep the encoding to UTF-8 in QGIS 3.22 when using tools in the Qgis toolbox?

Is there any equivalent to this setting/data source/option in QGIS 3.22. I would like to have the default encoding of UTF-8 (right now it change the files into windows1250 when running tools in the ...
Kristina's user avatar
1 vote
2 answers
557 views

Problem with Geoserver SLD Style Encoding UTF-8 Chars

I have installed Geoserver 2.20.1 with Java JDK 15.0.2 ON Windows Server 2012 R2, when i add a new SLD style including UTF-8, Geoserver does not understand UTF-8 chars
GIS Man's user avatar
  • 1,113
4 votes
2 answers
988 views

QGIS 3 doesn't propertly read umlaut from shapefile encoded in UTF-8

I'm using shapefiles with encoding UTF-8 that were used in ArcGIS before. The German umlaut ( ¨ ) are shown as a question mark. In Layer Properties -> Source -> Settings the encoding is set to ...
geofee's user avatar
  • 631
4 votes
1 answer
411 views

Errors when copy from shapefile to PostgreSQL using ogr2ogr

I am trying to upload data of MULTIPOINTS for listed buildings in Wales in shapefile format to a PostgreSQL database I have run the command below: ogr2ogr -progress -update -append -f PostgreSQL "...
user7993425's user avatar
0 votes
0 answers
56 views

Join between census shapefile and census CSV yields attribute table columns populated in disorderly fashion

I am using QGIS 3.10 to display American Community Survey variables at the census tract level. Last week, I successfully joined three ACS tables to duplicated copies of census tract geometries (same ...
infinitejost's user avatar
1 vote
0 answers
482 views

Encoding GeoJSON to something other than 'UTF-8' from QGIS

I want to save the shp file as GeoJSON and encode it to system, but my QGIS is disabled for selecting an encoder. Adjusted the 'ignore shapefile incoding declaration' option, but it did not work. I ...
DHKim's user avatar
  • 11
0 votes
1 answer
1k views

Error when unzipping LiDAR data with LAStools

I try to unzip LiDAR data (.laz) with LAStools under QGIS 3.4 but I get following error message : Traceback (most recent call last): File "path\to\LAStools\laszip.py", line 61, in processAlgorithm ...
dmjf08's user avatar
  • 1,233
2 votes
1 answer
102 views

Write accent mark in .shp and .dxf filename

I'm trying to export with python 2.7 some shapefiles and CAD files that could have specials characters in their filename, like accent marks. In example, I want to have this: ...
Fran Martin Rivas's user avatar
5 votes
1 answer
290 views

T-rex tile server with PostGIS (Windows) : utf-8 encoding error

I want to use T-rex as vector tileserver on Windows. I load osm.pbf file (from geofabrik) to PostGIS database with osm2pgsql successfully. When I run the server with the following commands, I get the ...
David's user avatar
  • 93
2 votes
0 answers
1k views

How to get a shapefile DBF encoding?

I wrote a python code that is used in different countries. It process a shapefile DBF, that can be encoded in any of the local langage (or being provided by another foreign partner), or even in ascii. ...
Bruno von Paris's user avatar
2 votes
0 answers
236 views

ArcGIS 10.4 strange phenomenon with special Unicode Characters Column

I worked on this problem for a while and I have localized it pretty well now to ArcGIS 10.4 at its core (haven't tested 10.5): A column that contains special Unicode Characters (emojis) is not read ...
Alex's user avatar
  • 704
2 votes
1 answer
746 views

Writing Shapes with GeoTools: Data fields with UTF-8 content are invalid

i'm creating Shapes using GeoTools SimpleFeatureType, SimpleFeatureBuilder and featureBuilder.add(...). (i can add snips if requested) Data Source is postgresql. Displaying the shapes with QGIS ...
wambacher's user avatar
  • 311
2 votes
1 answer
57 views

Showing images with special chars in path in map tips?

I do show jpg images through map tip's html. But if image's path has special characters (çãõ...) then map tip is not able to render it (the path to the images is directly writen in the html). If i ...
galderantzuna's user avatar
1 vote
0 answers
354 views

Invalid character in UTF-8 when geocoding in QGIS

I am using QGIS 2.18. As suggested, I installed the MMQGIS plugin to help me geocode the csv file containing a list of addresses. I converted the file to utf-8 encoding format. But when i was trying ...
May Lai's user avatar
  • 41
2 votes
0 answers
977 views

QGIS not recognizing special characters and problem with intersection?

Started playing with QGIS recently and I have encountered a problem. I have a layer with administrative areas of my country and when adding it the encoding is set to UTF-8. When I open its attribute ...
master_of_mediocrity's user avatar
4 votes
1 answer
1k views

How to make a vector layer with Hebrew caption in Qgis?

I am working in Qgis and need to make layers with Hebrew caption. When I make a new layer and write a word in Hebrew, in this case on a point vector layer that I made, it looks just fine. However, ...
Nitzan Matan's user avatar
  • 2,847
6 votes
1 answer
5k views

Change default data source encoding in QGIS to utf8

Working in languages with special characters, I always struggle with remembering to change the data source encoding from system to utf8 when I import files. Is there a way to have it automatically use ...
Henrik's user avatar
  • 369
2 votes
0 answers
543 views

PyShp ASCII encoding error

I want to filter a set of Point Shapefiles using PyShp. That works fine with one of the file sets (one point shapefile) but throws an error for another set that states: UnicodeDecodeError: 'ascii' ...
Homerun_'s user avatar
  • 125
12 votes
1 answer
8k views

og2ogr character encoding problem

When I'm dissolving a shapefile: ogr2ogr "b:\out.shp" "b:\Tele.shp" -dialect sqlite -sql "SELECT ST_Union(geometry), nev, jar FROM Tele GROUP BY jar" I got error message like: Warning 1: One or ...
STO's user avatar
  • 317
1 vote
0 answers
891 views

Avoiding GDAL ERROR 4 / Python - UnicodeDecodeError:?

I'm developing my QGIS-plugin. Unfortunately I faced a problem I can't solve. Plugin works pretty fine, until user hendles non-ascii characters inside input or output paths. The problem occures when ...
Janek's user avatar
  • 111
0 votes
1 answer
156 views

Preventing GDAL-dissolve from ignoring attribute encoding?

Given a huge shapefile which needs desolving by one attribute field to reduce redundancy. The GDAL dissolve functionality does that quite swiftly but the output attributes change the encoding so äöü ...
maxwhere's user avatar
  • 1,158
5 votes
1 answer
1k views

UTF-8 CSV import ok but after processing with utf-8 shapefile accent replaced by '?'

I m using QGIS 2.18 I export data from SQL Developer to a csv file with ";" as separator and with UTF-8 encoding. Then, I have imported the csv with UTF-8 encoding. Accents were imported right. ...
jlSta's user avatar
  • 1,094
4 votes
2 answers
910 views

MMQGIS Plugin error in QGIS 2.18

I've tried to geocode with MMQGIS Plugin a CSV file with addresses (converted from an Excel file) and I get an error: UnicodeDecodeError: 'utf8' codec can't decode byte 0xf1 in position 0: invalid ...
newGIS's user avatar
  • 4,042
11 votes
1 answer
12k views

Creating shapefile with UTF-8 encoded attributes with ogr2ogr

I'm using GDAL/OGR's ogr2ogr command line tool to export data from a PostGIS-enabled PostgreSQL database to various GIS file formats, Shapefile amongst them. To create a shapefile with the default ...
das-g's user avatar
  • 1,445
1 vote
1 answer
473 views

Can a table (.dbf) be encoded in two different systems?

I am having a *.dbf-file. When I load it into QGIS (delimited text-file) I am having trouble getting all the characters right. Either I load it in encoding=windows-1252 - then the headers will be ...
MichaelR's user avatar
  • 542
3 votes
1 answer
6k views

QGIS 2.14 Plugin Encoding Error

I've developed a plugin for QGIS 2.12 which uses data that is encoded in UTF-8. The plugin works fine for 2.12, but when I try to start it in QGIS 2.14 it throws me the following error: ...
TobsenB's user avatar
  • 902
0 votes
0 answers
888 views

geotools shapefile does not support utf-8 for dbf header

I create a ShapefileDataStore to create a new shapefile and call dataStore.createSchema(...) . But it does not work for utf-8 header fields. I checked the geotools source code and realized that it ...
Dariush's user avatar
  • 1,033