Questions tagged [wms]

A Web Map Service (WMS) is a standard protocol for serving georeferenced map images over the Internet

Filter by
Sorted by
Tagged with
0
votes
1answer
333 views

Can't load WMS service, “Failed to parse capabilities”

Using QGIS 3.8.1 and trying to load the QLG Gov base imagery WMS layer. It was working perfectly fine but then suddenly just stopped working and gave the message "Failed to parse capabilities". Tried ...
1
vote
0answers
36 views

WMS / imagery shuts down QGIS & kicks computer offline [closed]

please do not mark this as off topic - it is entirley ON topic. Have contacted QGIS/GitHub directly - no response. I am running QGIS 3.4.9 Madeira, but on loading WMS ortho-imagery (for North ...
2
votes
1answer
119 views

QGIS: Rendering WMS/WMTS raster at proper resolution?

QGIS 2.18.24 – which I use for work and cannot update – seems to struggle with some WMS and WMTS layers. They seem to render at an incorrect resolution, although they appear aligned properly. This is ...
1
vote
2answers
753 views

WMS GetFeatureInfo on a popup-Leaflet

I have the below code. When I launch this in Chrome, the map with the overlay displays fine and there is no error message in the console. However, there is no response when clicking on the map. I ...
2
votes
1answer
131 views

GeoServer WMS Layers not overlaying on OSM base-Leaflet

I would like to understand why I cannot view or see the WMS layers loaded. Based on the investigation I did so far, I am assuming this has to do with base layers projections. My overlays are WGS84, ...
3
votes
1answer
26 views

If there are many overlapping polygons at the location of GetFeatureInfo, how can I populate a template with information about all of them?

I have a layer with water basins, actually subbasins. Some of these subbasins (polygons) contain smaller subbasins. If I click on a smaller subbasin, a GetFeatureInfo request is sent to mapserver, and ...
1
vote
1answer
23 views

mapproxy.config - WARNING - unknow 'html' in sources

mapproxy.config - WARNING - unknow 'html' in sources.gasps_osm_source has thrown by terminal when i run : mapproxy-seed -c 16 --continue -f mapproxy.yaml -s seed.yaml , and no one tile has been cashed....
0
votes
0answers
19 views

WFS metadata open in MAP

I am working to replace our current version of GeoNetwork 2.8 to 3.6. We currently have WMS, WMST, and WFS type metadata. For WMS files when we change his link in the metadata register (in resource ...
1
vote
1answer
89 views

Geoserver WMS Layer decorations

I have created the layout directory C:\Program Files (x86)\GeoServer 2.15.1\data_dir\layouts In the directory I have created an xml file with the following: <layout> <decoration type="...
1
vote
1answer
42 views

Legend of WMS-Group Layer

I have a group layer and I want to show the legend of all layers in this group layer. For one layer in this group I get the Legend with this url: GEOSERVER/KRE_KANAL/ows?service=WMS&request=...
2
votes
0answers
64 views

MapServer merging features from layers in Template-Driven Output

I want to get WMS GetFeatureInfo result in GeoJSON format from MapServer. Result should be valid GeoJSON FeatureCollection containing array of features from one or more layers. I use Template-Driven ...
0
votes
0answers
27 views

Fixing QGIS generated SLD to avoid repeating polygon labelling [duplicate]

I have generated SLD's in QGIS that I use in GeoServer. Although the labeling shows fine when previewing the layer in GeoServer, when bringing the WMS in Leaflet then labeling repetition occurs. How ...
0
votes
0answers
10 views

What URL do I have to use if I want to get the legend of the root layer or a group layer with WMS Service

I get the legend of a WMS-Layer with this URL: MYGEOSERVER/GROUPLAYER/ows?service=WMS&request=GetLegendGraphic&format=image/png&width=20&height=20&layer=mylayer With https://...
1
vote
0answers
55 views

GeoServer WMS using NetCDF plugin and GRIB2 time dimension

I am attempting to use GeoServer with the NetCDF plugin to create a WMS-T (WMS with time dimension) service. My input is a GRIB2 file containing a single parameter (temperature) and multiple forecast ...
1
vote
1answer
40 views

Get WMS service properties for cql filtering?

From a wms service I know its url and a layer name called: CATAST_Pol_Municipio https://idena.navarra.es/ogc/wms I need to apply a cql_filter on a GetMap request on that layer, filtering by ...
0
votes
1answer
129 views

List of overlapping WMS layers [closed]

How do I get a list of layers by clicking on overlapping WMS layers in the Leaflet map? The best solution is to have the list in a single popup on the map. <!DOCTYPE html> <html> <...
1
vote
0answers
31 views

In WMS service Geographic Coordinate System changed from NAD 1983 to WGS 1984

In our project MXD it's Geographic Coordinate System is "NAD1983" and Projected Coordinate system is "NAD_1983_BLM_Zone_11N", and I published Map and WMS service from this MXD, while publishing in ...
1
vote
0answers
146 views

Leaflet Zoom on WMS-Layers - Error: Attempted to load an infinite number of tiles GridLayer.js [closed]

I use Leaflet 1.5.1 for showing WMS layers on a GeoServer 2.15.1. I can only zoom up to zoom level 14. If I continue to zoom into the map, I see the following error message. Error: Attempted to load ...
1
vote
1answer
28 views

LabelPlacement in high zoom and AnchorPoint

In the documentation of geoserver I found, that <AnchorPoint> <AnchorPointX> 0 </AnchorPointX> <AnchorPointY> 0.5 </AnchorPointY> </AnchorPoint> ...
2
votes
1answer
235 views

Error occurred decoding the EPSG code EPSG%3A3857 in GeoServer

My application is throwing the NoSuchAuthorityCodeException error although the layer preview in geoserver is working perfectly, they are not visualizing in the app. I have just checked the logs and ...
0
votes
0answers
27 views

Aggregate layer not loaded on GeoNetwork

I try to load an aggregate layer WMS from GeoServer on my GeoNetwork as base-map (i have changed the config-viewer.xml file) but an error displays that the tile is not found. Moreover when I try to ...
0
votes
0answers
42 views

Not able to render map from WMS to MapInfo using MapXtreme

I am trying to get the map from WMS which is hosted on GeoServer to the map. I am getting the layer of WMS but I am not able to display in the Map Screen. Here is my code to do so: ICapabilities ...
0
votes
0answers
69 views

Displaying one sublayer from WMS service to ArcGIS Pro using SDK

I have developed a new toolbar Add-In for ArcGIS Pro 2.4 with C# and ArcGIS Pro SDK in Visual Studio 2019. This toolbar has several buttons that load geographic information to a map canvas in ArcGIS ...
1
vote
0answers
54 views

How could I extract TMS and WMS link from ArcGIS Server?

I need link of TMS and WMS from our custom ArcGIS maps in order to use in qlikview. How could I extract this link?
1
vote
0answers
100 views

No GetFeatureInfo response when clicking on a map in OpenLayers 2

I have the code below, however no response when clicking on the map. <!DOCTYPE html> <html lang='en'> <head> <meta charset='utf-8' /> <title>My OpenLayers Map</...
0
votes
0answers
33 views

Load 2 layer in one base map geonetwork

i want to load 2 layers from geonetwork in one basemap on geonetwork !! so my question turn about how to configurate the file config-viewer.xml to support 2 arguments name in the same ows-context:...
0
votes
0answers
75 views

WMS GetFeatureInfo for multiple overlapping layers at the same time (Geoserver)

I have two layers served via GeoServer: "locations and "forests". I'm using GetFeatureInfo request to query the layers like this: mysite.net/geoserver/project/wms?REQUEST=GetFeatureInfo&SERVICE=...
0
votes
0answers
70 views

Slow seeding/caching from GeoServer WMS to MapPRoxy

I face a unormal speed of re-seeding (updating old tiles by new from one source - WMS GeoServer (in GeoServer this data taken from PostgreSQL source)) from 5.32% to this [08:39:10] 11 5.42% -...
0
votes
0answers
36 views

How can I publish a password protected WMS Service with ArcGIS Server 10.5.1?

Is is possible to publish a password protected WMS service using ArcGIS Server 10.5.1 and if yes how?
0
votes
0answers
46 views

mapproxy seeding optimisation. Internal HTTP error

We are using mapproxy for caching our own big data from geoserver. When I run seed : mapproxy-seed -continue -f mapproxy.yaml -s seed.yaml the terminal sometimes throws this warning (like in this ...
2
votes
0answers
195 views

Add WMS to matplotlib Python

Currently I am adding a basemap from stamen.com to my plots as it is explained here: http://geopandas.org/gallery/plotting_basemap_background.html . Is it also possible to load a WMS from another ...
0
votes
0answers
63 views

Clip the BBOX coordinates

Is there any control on BBOX to clip the coordinates before sending request to the GeoServer. The allowed coordinates are [-90, 90, -180,180]. The issue is when ZoomIN/out the BBox calculating the ...
0
votes
1answer
300 views

How can I get GeoServer WMS layer attributes in QGIS?

I am trying to connect GeoServer wms layers in QGIS for the purpose of web mapping. The layers are shown properly in QGIS but the layers attribute that means layer information is not visible in layer ...
2
votes
1answer
251 views

Displaying Bing Maps WMS in QGIS?

I am trying to display my bing map raster tiles in QGIS. I am using an HTML file like this, except with my own raster tiles, as described in WMS Tile Layer Example. My own raster tiles don't have a ...
1
vote
1answer
29 views

Pop up appearing blank after JSON parse?

My aim is to retrieve the attribute list of a WMS layer. The concept is to fetch it as JSON data, then parse it and display it in a pop up. I am using OpenLayers3 with local GeoServer and JavaScript. ...
3
votes
0answers
125 views

EPSG:25833 in LeafletJs [closed]

I am currently working on the different coordinate system. Specifically, I am concerned with the correct presentation of EPSG:25833 (ETRS89/UTMZone89) in Leaflet. If I am right Leaflet used as ...
1
vote
1answer
310 views

GeoServer - longitude/latitude is out of bounds

We could see the below error from GeoServer when zooming out the map, because the bbox sending request more than the MONGO DB accepted range(-180,-90,180,90). "Query failed with error code 2 and ...
0
votes
0answers
132 views

Changing custom parameter of WMS layer in ArcMap or ArcGIS Pro using ArcPy?

In a web mapping application developed with ArcGIS JavaScript API (3.29) I am utilizing a WMS service describing Radar data from https://mesonet.agron.iastate.edu/cgi-bin/wms/nexrad/n0r-t.cgi . This ...
0
votes
0answers
54 views

Provide WMS Service through QGIS Server

I'm trying to figure out how to provide WMS - Services with QGIS and in my Research I encountered QGIS Server. But I'm still uncertain about how it actually works. I install Apache Webserver and ...
1
vote
0answers
73 views

GeoServer GeoTIFF not rendering properly in QGIS and GeoServer Previews

I have a WMS raster ortho image that I have published as a GeoTIFF on two different GeoServers, a development server and a test server. On the dev server the image can be previewed in GeoServer just ...
1
vote
1answer
53 views

Serving enormous WMS with GeoServer?

I have an entire Spain agronomic parcels layer in a PostgreDB and I´m triying to serve it through GeoServer. I split by villages to improve the speed of the petitions, but how can I serve all the ...
0
votes
1answer
237 views

Getting attribute list of a particular WMS layer and display it as a popup in OpenLayers3?

I have an OpenLayers3 map with two layers provided from local GeoServer.My requirement is to get the attribute list of one layer and display it as a pop up inside the map window. To achieve this, I ...
1
vote
1answer
59 views

Can't see multiple layers when adding a WMS

I am using QGIS 3.8.2. I have a WMS (https://openwms.statkart.no/skwms1/wms.topo4.graatone?) that I want to add, and in Arcgis it lists several layers (33 total) in the table of contents. When I add ...
1
vote
0answers
95 views

QGIS WMS mapserver not showing all layers

I'm publishing a map via qgis_mapserv.fcgi and the WMS behaves strangely, without giving me any errors or other clues as to what might be wrong. I am wondering: is the problem with using GeoJSON as ...
1
vote
1answer
71 views

GeoServer different styles for one layer?

In GeoServer I have a layer created from a database table with the following structure: tableX ( id,name,typeid,description,geom ) The geom field is always a polygon. I also have created 3 ...
2
votes
3answers
297 views

Enable WMS GetFeatureInfo request in Leaflet using R?

I've been using R with Leaflet and Shiny to produce a web map that is accessible to the public online. It is a real-time air temperature map of Tasmania, Australia based on current Bureau or ...
0
votes
0answers
59 views

Can't run mapproxy server: SyntaxError: invalid syntax

I have successfully installed a MapProxy == 1.8.0. And I have set mapproxy-util create -t base-config gasps But when I run server, using mapproxy-util serve-develop mapproxy.yaml Console throws it: ...
1
vote
1answer
36 views

Is a WMS of vectors a stream of images or of data attributes?

I used to read that WMS is a stream of images, for example : image/png. And that, if you need additional data about what is underlying, you have to send WFS requests aside. But what about WMS streams ...
0
votes
1answer
40 views

OpenLayers map with custom projection not showing WMS

Trying to add to my map an WMS layer with custom projection When executing, the map does not show any layer. Custom projection: proj4.defs("EPSG:25830","+proj=utm +zone=30 +ellps=GRS80 +towgs84=0,0,...
0
votes
0answers
125 views

Applying authentication in GeoServer

I am trying to apply basic authentication in GeoServer but somehow it is not reflecting while consuming the WMS service through OpenLayers. I am accessing it thorough below urls: http://admin:...

1 2 3
4
5
38