Hot answers tagged

56

I just had the same problem on Ubuntu Server 14.04. I installed the postgis extension from the official Ubuntu repositories using apt-get install postgis. Then, find /usr -name postgis.control didn't return any results. The reason was extension/postgis.control wasn't installed because postgis-scripts wasn't. $ aptitude search postgis i libpostgis-java ...


18

In Ubuntu 14.04 you also need to install the postgresql-9.3-postgis-scripts package. After I ran sudo apt-get install postgis postgresql-9.3-postgis-scripts I was then able to successfully run CREATE EXTENSION postgis; in my database to initialise PostGIS.


12

If you can find a postgis.sql file, you can run that into your database (and the spatial_ref_sys.sql file) to manually spatialize your database. Report the missing control file to the packager, that's a big problem.


11

I found this answer which pointed me in the correct direction: https://gis.stackexchange.com/a/120103/442 I just had to update the GDAL version there. These are the commands that I used to get a successful deployment of GDAL v2.x #Install the tools that we will use yum groupinstall "Development Tools" yum install wget #for Postgresql support sudo yum ...


7

To avoid "layer is not valid" errors you should carefully set your QGIS prefix path. The prefix path must be set to let QGIS know where to find resources such as data providers and the reference system database. If you look at your QGIS installation, you should be able to access lib/qgis/plugins on Unix (or just plugins on Windows), relative to the prefix ...


7

We tend to install the Anaconda Python distribution, which also includes a fairly complete GDAL version in conda-forge. All you need to do to make it work is to add your anaconda directory to $PATH. You get the Python bindings, but also the binary executables (e.g. gdalinfo and friends). You can also use the recipe on conda-forge to build your own version ...


5

In your screenshot, you should set CRS ID to 3857, and check Y origin top. Then you can zoom in to get higher zoom levels. BTW you can activate the original Openstreetmap basemap as a reference. Apart from that, the tiles are not IN your postgis DB. You have stored raw OSM data in there, and the mapnik toolchain delivers tiles upon request to the ...


4

ELGIS requires EPEL (see https://fedoraproject.org/wiki/EPEL/FAQ#howtouse for EPEL). However I'm not sure that you really want to use ELGIS 6 on CentOS 7. Its intended for RHEL 6 / CentOS 6 / Scientific Linux 6. Instead, you probably just want to use EPEL for CentOS 7 for something like GDAL. EPEL 7 has GDAL 1.11.0, which isn't quite the latest, but is ...


4

The -P argument to psql is not used to supply a password; see the documentation at this link. You can supply a password to psql using one of three methods: Enter the password at a prompt Enter the password in your ~/.pgpass file Set the PGPASSWORD environment variable Maybe your Mint system has the password defined using #2 or #3? If not, perhaps the ...


3

Trying to build from source without root access is near impossible on CentOS. I have figured out that really the only practical way to solve this issue is using a conda package (for the Anaconda python distribution) built by Jose The solution is to run this on a fresh install of Anaconda (step three being the important one): conda update conda conda update ...


3

I had the same issue, I just ran the command sudo apt-get install postgis I was using Ubuntu 18.04


3

Judging from the last few lines of output: checking for g++... no checking for c++... no checking for gpp... no checking for aCC... no checking for CC... no checking for cxx... no checking for cc++... no checking for cl.exe... no checking for FCC... no checking for KCC... no checking for RCC... no checking for xlC_r... no checking for xlC... no checking ...


3

You'd have to install the repository first sudo rpm -Uvh http://elgis.argeo.org/repos/6/elgis-release-6-6_0.noarch.rpm Then to install QGIS sudo yum install qgis qgis-python qgis-grass qgis-mapserver or try this sudo yum --enablerepo=elgis install qgis qgis-grass qgis-python qgis-mapserver If that still doesn't work, could you try searching for it in ...


3

Install QuickMapServices Plugin (https://plugins.qgis.org/plugins/tags/qms/) Add your TMS source Enjoy


3

You may also compile from source (so you do not mess rpms) wget https://download.osgeo.org/postgis/source/postgis-2.4.4.tar.gz tar xvzf postgis-2.4.4.tar.gz cd postgis-2.4.4 ./configure --with-pgconfig=/usr/pgsql-9.5/bin/pg_config make make install Install the following dependencies before compiling: yum install geos-devel.x86_64 yum install proj-devel....


2

You can test whether the WMS service is configured correctly by making the GetCapabilities request directly in a browser http://***************/cgi-bin/projects/qgismapserv.fcgi?SERVICE=WMS&REQUEST=GetCapabilities The format of the request in your question is correct, so if you get an error the server is not correctly configured. You will need to look ...


2

If you're willing to do the compiling yourself, then you might follow my instructions here. (EDIT: pasted to avoid linkrot) We’ll assume you already have a build environment with gcc-c++, flex, bison, PyQt4 etc. Check the QGIS wiki wiki page for details regarding dependencies. While the instructions are specific for Ubuntu systems, it’s fairly clear which ...


2

Another source which caused the problem could be the missing PostGIS bundle, this can be defined in install menu or in your case afterwards. Therefor, open windows start, head to PostgreSQL an start the Application Stack Builder. Then select PostgreSQL, with that possible applications are loaded. For the PostGIS bundle you just need to install the extension ...


2

I used the following to successfully install QGIS with Python Plugin support on a CentOS 7 minimal install: Install CentOS 7 minimal Install a GUI Desktop yum groupinstall "GNOME Desktop" Install QGIS+Python Support and supporting packages yum install qgis qgis-python python-devel PyQt4-webkit proj-devel geos-devel sqlite-devel gcc Python Requirement: ...


2

The wps module is a separate package on Linux. yum install geoserver-wps should do it.


2

For CentOS 7: You will need two prerequisite packages before installing the GDAL pip package. yum install gdal-devel gcc Then you should have the required packages to install via pip pip install GDAL


2

I just found the solution, it's about cache in QGIS. I turned off use the cache rendering if possible, it's a bit slower but all the tiles are downloaded correctly now.


2

I encountered the same error concerning SFCGAL library and I solve it installing the corresponding devel library e.g. on Centos 7.4 sudo yum install SFCGAL-devel I hope it can be useful also for you


1

alternative to googledrive is aws bucket! this tutorial: S3 Bucket Mounting as a File System in Linux using S3fs and S3fuse this is good,easy management,low price an fast especially for geoserver tiles(geoserver)


1

Probably, there is a problem from Apache to access the directory /var/www/html/wms I had the same error with myproject.qgs that was in a different directory: /var/www/wms The problem has been solved with insert of some directives in this configuration file: /etc/httpd/conf.d/qgis-server.conf RewriteRule ^/wms/(.+)$ /qgis/qgis_mapserv.fcgi?map=/var/...


1

try to find qgis rpms in rpmfind.net and install them manually http://rpmfind.net/linux/rpm2html/search.php?query=qgis


1

Bit of a cr@ppy answer - but it works. Unfortunately, it doesn't really solve the route cause. I resolved my issue by changing the build to use static libraries instead. ./configure --with-fgdb=/data/HOMEDIRS/SAI/dev/src/FileGDB_API --with-pg=/usr/bin/pg_config --prefix=/usr --without-ld-shared --disable-shared --enable-static


1

GDAL itself can certainly be built and used/installed without root access on most *nix type systems. In these cases, I usually create a file structure to contain both the final GDAL build itself and all of its dependencies that the host OS doesn't already have. But, you could have them in separate folders as well as long as you have your path, LD_CONFIG, ...


1

Have you checked the Tomcat/ Geoserver logs for errors? I am curious if there are java memory errors that might be influencing the error you described. I have noticed CPU and memory go through the roof when caching wms layers on the fly from large tables. Your system is pretty robust but you will need to configure java to utilize the system to your needs. ...


1

You have installed a newer version of geos (3.4.1 vs 3.3.8) on your system, which is from the opengeo repository. QGIS-Grass requires 3.3.8 to run. You can downgrade this library to version 3.3.8 from the elgis repo, but that may fail, if other applications requires the newer library. In which case you have to decide if you want to keep the other ...


Only top voted, non community-wiki answers of a minimum length are eligible