2

I got it working by setting the 'metadataUrl' type to 'TC211' in geoserver e.g. GetCapabilities response looks like this: <Layer queryable="1" opaque="0"> ... <MetadataURL type="TC211"> <Format>text/xml</Format> <OnlineResource xlink:type="simple" xlink:href="https://...


1

That seems like a pretty clear error message "java.lang.OutOfMemoryError: Java heap space" - you have run out of memory for the JVM heap. You will need to allocate more memory to the JVM using -Xmx6g or any other amount you care to use. See also the GeoNetWork manual discussion.


1

You'd need two calls, one to the CSW-T service to create the metadata record and other to store the JSON file in the filestore using the GeoNetwork API: POST /{portal}/api/0.1/records/{metadataUuid}/attachments You can check the parameters here https://vanilla.geocat.net/geonetwork/doc/api/index.html#/records/putResourceFromFile


1

Reinstallation solved the issues in the end.


1

Using the config UI is the right way of setting the proxy in GeoNetwork. Setting it through JVM command line options also should work. If it isn't working I'd suggest you to open a bug report in GeoNetwork Github describing the problem so the developers can fix it.


1

Typically you would use the CSW GetRecords operation, which allows to to filter on location, properties, and sorting/paging. You can find numerous examples (for any CSW) from the pycsw tests. In addition, checkout the sample pycsw viewer for an example application. Be sure to view the HTML source and enable to web console to see client/server ...


1

Problem solved! Had server address incorrect. Path should be http://gdcs1.gdc.com/Metadata/Thumbnails/Geo_125k/XXXXX.jpg


Only top voted, non community-wiki answers of a minimum length are eligible