14

The answer from Wilfried Thuiller in R-SIG-Geo mailing list works: #getting a raster library(raster) f <- system.file("external/test.grd", package="raster") f r <- raster(f) #r is the object of class 'raster'. # replacing NA's by zero r[is.na(r[])] <- 0


4

The usual problem with kriging is duplicate locations. You can note that even the function autoKrige gives you the following warning: Removed 197 duplicate observation(s) in input_data You can also compare length(hs1@coords) and length(unique(hs1@coords)), which gives you results 1104 and 730 respectively. If you use for example the following construct to ...


4

Open your attribute table and add a new field for Longitude (if it doesn't already exist). Right-click on the new field in the table and select "Calculate Geometry" In the Calculate Geometry dialog that appears, ensure that X Coordinate of Point is selected, the coordinate system and units are correct, and click OK. This will populate the field with the ...


3

"external/test.grd" isn't the best way to test this. Is a very small raster, so results can't be applied in a large raster. Here I present a comparison with 4 different approaches, the file used is a mosaic of 12 tiles of ALOS DEM 30m (size per tile: 1x1 degree). Options a and b are the most suitable for small rasters, let's see if they are good for big ...


3

I'm not aware of any way to do it from within QGIS but GDAL can do it from the commandline. The basic steps are: Crop, upsample, and smooth your low-res data to match your high-res data; you may also need to reproject the SRS. You can determine the appropriate parameters by running gdalinfo against your DEM files. SRC_SRS should match the value from your ...


3

GPSBabel has a function for this. To take a GPX input file and interpolate points so that each is 30 seconds apart: gpsbabel -i gpx -f INPUT.gpx -x interpolate,time=30 -o gpx -F OUTPUT.gpx Arguments: -i gpx: input file type is GPX -f INPUT.gpx: filename is INPUT.gpx -x interpolate,time=30: apply a filter (x), using interpolation, interpolating any points >...


3

If you want the average value, then you could use a mean filter (focal statistics, ignoring the NoData value). This will be way faster than kriging, and it will work directly from a raster. Then you use the raster calculator to replace the nodata values with the mean values : Con(Isnull("input_raster"), "smoothed_raster", "input_raster") As a remark, ...


3

If you export your Excel sheet to a geodatabase table, the blank values will remain blank, they won't be converted to 0. One of the ways you can do this is by right-clicking the Excel sheet in the Catalog > Export > To Geodatabase (single)...


2

Kriging is a stochastic technique and you have observations of variable quality. The specific estimation technique you use ought to be able to allow variable weighting of your observations. In your case such weights would be proportional to 6 versus 24 (or perhaps M versus N) so that observations bring appropriate weights. (I don't know, however, which ...


2

As @Mapperz says: Illustrator has a display limit around 60,000 vertices per feature you need to split lines or generalise your data down before export. You can generalise the lines down before exporting and entering in to Illustrator. You can generalise lines with Vector > Geometry Tools > Simplify Geometries


2

If I remember correctly there is a tool under Data Management > Features > Add XY Coordinates. Something along those lines, that should give you two new columns in the attribute table with the information you need. Your question should state the current projection on the file you're having this issue with.


2

You have an indent error with your second pass. fix the indention after your else and the toolbar should work. I've found that finding errors with custom toolbars can be tricky. I suggest testing them a few lines at a time so that you can have a clear understanding of where they fail when they fail. Go slow. Also note that if your python window in ArcGIS is ...


2

If every shapefile is missing the last feature then I would think the error is coming from the "blackbox" exporting to shapefile. You should ask to see the code that is used for exporting to shapefile.


2

First select from the attribute table the feature which is missing and save it as a separated layer. Is it still undisplayed? Try to check its geometry using the field calculator. Add a new field with geom_to_wkt( $geometry ) as expression. (If you have only the one feature you don't even have to add the field, you have a preview after typing the expression)...


2

SOLVED. The only u need to do is install all dependencies of qgis... https://www.archlinux.org/packages/community/x86_64/qgis/ sudo pacman -S fcgi gpsbabel gsl python-jinja python-numpy cmake python-six qt5-tools txt2tags


2

Ok, turns out I imported the csvs with "discard empty FIELDS" left on as is default. Because the column of data I needed was the last one, and the intermediate columns included blank entries, inexplicably this means that QGis slides all data left, such that the only remaining data in the rightmost column will be for those rows which have no blank values. In ...


2

What I am looking for is a function to use in conjunction with mask that ensures that in the final masked raster these NA values are removed so that I have raster with no NA value. A raster is an NxM grid where every cell has a value. If the value is not known, it is generally set to NA (or some special value like "-9999"). There's no way you can "remove" a ...


1

The issue feels similar to this one but it is corrected in GDAL four years ago https://trac.osgeo.org/gdal/ticket/5608. The changeset https://trac.osgeo.org/gdal/changeset/27577 does even contain a test case. Do you know if the blackbox software happens to use an ancient shapelib version which is less than 1.2.7?


1

No, as Ian Turton says you can't add data from Google to OSM. You can get more information on what are suitable sources for OSM here and here.


1

What appears to be happening is that the objectID index is corrupt, and this cannot be fixed directly. Some or all data may be recoverable by using export to xml and reimport to xml options (harder but it worked for me) or by using the file geodatabase recovery tool (easier but it did not work well for me). You will be creating new files from your existing ...


1

I think you can use raster::calc() as perhaps a more memory efficient method. So, guessing that you have a single-layer raster you can do the following to replace NA values (used some test data here): library(raster) r <- raster(nrow=1E3, ncol=1E3) values(r) <- NA replaceNA <- function(x, na.rm, ...){ if(is.na(x[1])) return(0) else ...


1

Open ArcMap and import the layer > Right click and Open Attribute Table> Click on Table Options (upper left corner of the Attribute Table) and select Add Field > Right click on the new field title and select Calculate Geometry.... It gives you the option to calculate the longitude and latitude (X, Y) of the features, using either the data source coordinate ...


1

You can do this from within the QGIS GUI using Processing -> GRASS -> r.patch (https://grass.osgeo.org/grass70/manuals/r.patch.html), which will fill in areas of no data in an input raster using data from another raster. This does not do any form of smoothing though, so you will still end up with blocky edges as per the answer from @Alex Hajnal above.


1

The only time I have had a similar issue, it was because my Processing Extents were out of wack. Here is what I did: Go to Environment Settings > Processing Extent > Extent: Union of Inputs. I'm not sure if this is the issue, but hope it helps.


1

The simple way to start doing this will be to use the Polygon Neighbors tool to determine the neighbors of each polygon. There is detailed documentation on how How Polygon Neighbors Works because it is a very flexible tool. If it does not do what you need then it should be possible to post-process the output using ArcPy cursors to do so.


1

Ok, I've gotten it to work! Executing from commandline seems to be irrelevant, temp file seems to have been irrelevant. What did work is I changed pixel search distance to 10 (just for the test), and then unchecked "band to operate on" and "do not use default validity mask". Only loaded 1 band at a time into QGIS. Now I'll tweak from here.


1

It may not matter but it appears you're output file is going straight into a tarball. You could try outputting (and reading from) elsewhere. You could also try executing the the gdal_fillnodata command directly in GDAL commandline/shell (e.g. copy and paste the command from QGIS window, start the OSGEO4W shell, paste and execute).


1

First of all, I would suggest you to save your layer as a new layer once you have performed the simple join, in order to properly save the new attached columns in the layer attributes table. To achieve that: in the TOC, right-click on layer to save > Save As... and select Esri Shapefile for instance, which is the most currently used format (unless you need a ...


1

If you still need TRMM data there is a new QGIS plugin that allows you to download the 3B42 product. You can download the original data, with a 3 hours frequency, but you can also aggregate it in daily layers. The data is available from January 1st 1998 to July 31st 2015. You can browse the plugin page here: https://plugins.qgis.org/plugins/...


1

Solved! The new version of Drive was the issue. I have gone back to the old version and all my files were there.


Only top voted, non community-wiki answers of a minimum length are eligible