Hot answers tagged

4

I was able to get it working with the following Nginx settings: location / { proxy_pass http://127.0.0.1:8080/geoserver/; proxy_pass_header Set-Cookie; proxy_set_header Host $host; proxy_set_header X-Forwarded-Proto $scheme; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; } location /geoserver/ { proxy_pass http://127.0....


3

You are experiencing a Cross-Site Request Forgery problem, GeoServer thinks that some one is spoofing your requests. This is solved by adding the proxy to a "white" or allowed list of machines that can make requests. This is described on in the GeoServer manual


2

This is a known issue and is due to an (unplanned) increase in security when Spring was upgraded. One suggested work around is to add <session-config> <tracking-mode>COOKIE</tracking-mode> </session-config> to the web.xml file.


2

At the bottom of the manual page is this note: The rule of thumb is that resources (layers, styles, etc …) belonging to an isolated workspace can only be retrieved when using that workspaces virtual services and will only show up in those virtual services capabilities documents. So you need to feed your virtual service endpoint through Nginx to work out ...


1

You seem to be following the instructions for a jetty install rather than the ones for tomcat with the result that tomcat is trying to process a Jetty jar and (understandably) crashes.


1

Digging deeper, I was able to find another file on my system that was adding the DENY option, using the following command: sudo grep -ri "X-Frame-Options" / Once I made the appropriate edits to those Nginx config files, everything worked great. In short, the issue was due to cascading config files, and me not realizing there were additional config files ...


Only top voted, non community-wiki answers of a minimum length are eligible