Hot answers tagged

12

I believe that is a problem of the filesize of the WAR file of geoserver. At default tomcat only accepts 50MB in the WAR files to upload, open with notepad the file: C:\Program Files (x86)\Apache Software Foundation\Tomcat 9.0\webapps\manager\WEB-INF\web.xml and find the lines with the text: <max-file-size> and <max-request-size>. Increase ...


8

This problem occurs when your .war is bigger than the value in config file of the tomcat manager. You need to set the config in web.xml from the tomcat manager. The file will normally be in %tomcat installation%\webapps\manager\WEB-INF\web.xml Look for: <multipart-config> <!-- 50MB max --> <max-file-size>52428800</max-file-size> ...


7

Ciao, generally speaking I would give GeoServer an amount of heap memory between 1GB and 8GB. It is rather difficult that it will use more than that. It would actually be great if yoy could say more about what kind of data you are serving with GeoServer and which kind of requests you are usually sending to it. A stack trace might help as well. Generally ...


5

Well, I gleaned this information from many different posts. There are several "answers" out there, but I only found one that actually worked. First of all, if you are running Tomcat 8.0 as a service in the Windows OS, those BAT files (catalina.bat, setenv.bat if you created one) do not seem to be relevant at all. There are many who say "edit catalina....


5

The best way to do this is with a Reverse Proxy in front of GeoServer. You can do it with Nginx. Here's an example: https://gist.github.com/thanhleviet/3040490 The 'proxy base URL' setting in GeoServer allows you to tell GeoServer that it is behind one of these proxies, and adjusts all it's WMS Capabilities URLs and such (from my understanding).


5

A colon : between the workspace and the layer is missing. If the layer exists in the provided workspace, the URL below should work: Request URL: http://<domain>:<port>/geoserver/<workspace>/wms?service=WMS&request=GetMap&layers=<workspace>:<layername>&styles=&format=image%2Fpng8&transparent=true&version=...


4

I had to change the catalog mode to mixed! The issue had nothing to do with the dispatcher servlet mapping. The "no handler mapping found" warning still exists but everything works like before.


4

The real cause of the issue is the max-file-size limit in WEB-INF/web.xml. It is set for 50MB while the geoserver.war (version 2.9.0) is over 65MB. Open the file below for tomcat7: sudo nano /usr/share/tomcat7-admin/manager/WEB-INF/web.xml Locate multipart-config tag and turn 50MB to 500MB.


4

geoserver.exe installs GeoServer as a windows service (or optionally as a manually started program) running inside Jetty. geoserver.war is a platform independant war file that needs to be installed into a container server (e.g. tomcat, jboss, jetty etc). The downside of using the exe installer is that you have to be on a windows machine, you also get less ...


3

Your first app is attempting to load the web map from a file:// uri (see the Chrome console error: "Unable to load file://www.arcgis.com/sharing/...") and not http (or https) as it should. Are you sure you are hosting the html in a page served out by your web server and not just double clicking it to open directly from the file system?


3

Yes, you can use exactly the same mechanism to limit access to any web application. If the web application doesn't have a context.xml file you can simply create an empty one and add what you need.


3

I suspect an out of memory error: the first application to be accessed will issue a large (how many features are fetched with every layer?) WFS request which completes, but prevents further requests from being carried out successfully. This explains the works-after-restart behaviour as with a restart all JVM memory would be released and then reallocated ...


3

The issue is to do with the Tomcat settings and not with any settings of GeoServer. Note the Tomcat docs tell us: It should be noted that it is not recommended to use a reverse proxy to change the context path because of the multiple issues it creates. So if you want to run GeoServer under a different name you might consider changing the name of the ...


3

There a two or three possible reasons that come to my mind: Option1: your Webserver is not configured properly: What happens for example if you try to access this site(presuming that you put your proxy.cgi in your usr/lib/cgi-bin -folder): http://yourserver_ip_or_adress/cgi-bin/proxy.cgi?url=http://www.openstreetmap.org If you wont see the openstreetmap-...


3

To deploy you can copy the war file in /var/lib/tomcat7/webapps


3

GeoServer is a servlet and always runs inside a servlet container (e.g. tomcat, jetty, JBoss etc). So your question is "how do I change the port of the container that GeoServer is using?" which is what the question you point to is answering. On the OSGeoLive VM there are two tomcat containers running one on port 8080 and the other (with GeoServer) on 8082. ...


3

GeoServer's GDAL extension is very picky about the version of GDAL you need - please follow the instructions in the extension documentation. This is due to the way the JAva to C(++) bindings work and to be honest is something of a mystery to Java developers but seems to keep the C++ boys happy.


3

On startup GeoServer loads the configuration of all layers, to be kept in memory. The process makes it load NumberOfLayers*2 files just for the layers, plus all styles, stores and whatnot. While I cannot be sure that is the problem, it seems that GeoServer is going to take several minutes to startup in those conditions, and the situation will worsen daily. ...


3

Edit the Tomcat webapps/manager/WEB-INF/web.xml file, change the section like <multipart-config> <max-file-size>52428800</max-file-size> <max-request-size>52428800</max-request-size> <file-size-threshold>0</file-size-threshold> </multipart-config> Updating the <max-file-size> and <max-...


3

You need to enable CORS in your Tomcat, simply added to $CATALINA_HOME/conf/web.xml the following lines: <filter> <filter-name>CorsFilter</filter-name> <filter-class>org.apache.catalina.filters.CorsFilter</filter-class> <init-param> <param-name>cors.allowed.origins</param-name> <param-value>...


3

The WPS extension adds WPS capabilities to GeoServer, while the WPS-remote extension allows you to use "remote" processes. That is processes running outside of GeoServer. You install it in the same way as any other extension by downloading the zip file and unpacking it's contents into the WEB-INF/lib directory. You will also need to deploy a Python/XMPP ...


3

It looks like you are using the Jetty instructions on a tomcat server - try following the tomcat ones. You need to add the following to $CATALINA_HOME/conf/web.xml: <filter> <filter-name>CorsFilter</filter-name> <filter-class>org.apache.catalina.filters.CorsFilter</filter-class> <init-param> <param-name>...


3

If you're running Tomcat as Windows service, then tomcat8w can help to configure new JRE. Go to Tomcat/bin, find tomcat8w.exe, execute in commandline: Tomcat8w.exe //ES//Tomcat8 (Change Tomcat8 to your service name) you'll see the Tomcat 8 properties dialog Set the JAVA Virtual Machine to your new installed one. Please refer to question How to change ...


2

To work with geocoder in OTP please refer to this post. here There are some slight improvements to the above post though( I have to spent hours to figure them out!), these are as follows For Google basemap In config.js just add these codes after the OSM declaration in baselayers: new OpenLayers.Layer.Google( "Google"), Add the Google Maps ...


2

The short answer is you could, but you shouldn't. Messing with the internal Tomcat is not recommended and will likely give you issues with Esri technical support if you encounter issues with ArcGIS Server. I have done some playing about with the internal Tomcat at 10.1 and the message from Esri is, don't do it (understandably as it might have knock on ...


2

You forgetting to copy the *jni.so files to your shared library folder. As state on gdal java documentation http://trac.osgeo.org/gdal/wiki/GdalOgrInJavaBuildInstructionsUnix: To deploy you need gdal.jar in your class path, the 4 .so files (libgdalconstjni.so, libgdaljni.so, libogrjni.so and libosrjni.so) and libgdal.so in your shared library path. ...


2

Ciao, maybe I overlooked something but from the outside you are accessing http://mydomain.com/geoserver/ not http://mydomain.com:8080/geoserver/ as the default port for Apache HTTP is port 80, hence connecting to port 8080 on it would give you exactly that error. Regards, Simone.


2

Computing disk usage for the entire cache directory is expensive so there's a module in GWC called Disk Quota which maintains a running total for each layer as tiles are added and removed. By default, Disk Quota is turned off, which results in the 0 values you see. Turn on DiskQuota (in the sidebar under "Tile Caching") and it will start showing the correct ...


2

The page Building and installing the PHP GDAL extension in the Drupal Community Documentation is helpful. The main part being to download and install from source, php5-gdal from its github repository. Some development tools may need to be installed before-hand. phpize ./configure make sudo make install Then configure and enable the module. sudo echo -e ...


2

Yes, you have to use proxy. The only format that allows cross-domain (and cross-port) access is JSONP, not pure JSON.


Only top voted, non community-wiki answers of a minimum length are eligible