5

The inconsistency is caused by invalid points in the dataset. When I run (libLAS) lasinfo on the provided sample, I get: 1170966 Unclassified (1) 1565144 Ground (2) But when I execute: las2las -i sample.las --valid_only -o sample2.las I get much lower number of points: 448086 Unclassified (1) 633077 Ground (2) which is exactly what r.in.lidar ...


5

GDAL and QGIS have been compiled by the DebianGIS team for Raspbian which is ARM architecture, and they can be installed from the Jessie suite on Raspbian. You should be able to install Debian packages on your ARM Ubuntu, using dpkg. A search of the Debian Package Repository provides some builds of QGIS and GDAL for ARM*: GDAL-BIN QGIS *ARM64, ARMEL, ...


5

Rebuilding from source worked for me also. The problem wasn't realy system upgrade. Simply, creating extensions such as postgis_topology or postgis_tiger_geocoder threw exactly the same error. I advise also restarting postgresql service after rebuilding, just in case. Or better : -stop the service; -rebuild; -start again the service; And it might be ...


5

Finding the location of your current executable can be done with which and ls -l can show you where the symlink points: which osmosis | xargs ls -l If you know the location just follow the Install instructions for pre-built binaries: wget http://bretth.dev.openstreetmap.org/osmosis-build/osmosis-latest.tgz mkdir osmosis-new mv osmosis-latest.tgz osmosis-...


5

I put my comment as an answer: You need to set up the environment variable,export QT_QPA_FONTDIR=<path to font files> for example export QT_QPA_FONTDIR=/usr/share/fonts/open-sans But when using fastcgi you have to do something like: @geraldo nginx fastcgi_param QT_QPA_FONTDIR "/ usr / share / fonts / open-sans" apache SetEnv QT_QPA_FONTDIR / usr ...


4

The GRASS 7 meta-package made available last week had errors that cause this situation. The ubuntugis-unstable PPA maintainers have in consequence removed this meta-package. In a system where this rogue GRASS 7 meta-package was installed the fix is to remove all its packages and downgrade: sudo apt-get purge grass grass-core grass-doc grass-gui sudo apt-...


4

This is indeed a bug in the QGIS installer, and already has a ticket: http://hub.qgis.org/issues/16383 For the moment, only QGIS-LTR is running on trusty. You have to remove and purge the packages of QGIS 2.18 to avoid versioning conflicts: https://askubuntu.com/questions/187888/what-is-the-correct-way-to-completely-remove-an-application Or consider ...


4

QGIS LTR (2.14) is in the main 17.04 repository. The repository for QGIS latest release (http://qgis.org/debian) currently provides a QGIS 2.18 package for 16.10 but not 17.04, and the 16.10 package won't install on 17.04. The nightlies for the upcoming point release are available for 17.04, though. Currently that's the only way to install 2.18 for Zesty ...


3

The version name for Ubuntu 17.10 is artful therefore your repository statements must read deb http://qgis.org/debian artful main deb-src http://qgis.org/debian artful main This is clearly documented on the download page. jessie is a debian release, not a ubuntu release.


3

Simple rule: If you want to stick to a Ubuntu LTS (14.04), you must stick to QGIS LTR (2.14.4). Or get the latest from both worlds (16.04 and 2.16.0). The developers decided to do no additional backporting. You might well pay a developer for it if you can't/won't compile yourself.


3

The standard GIS tools GDAL, GRASS, SAGA CMD and Orfeo Toolbox work on the command line. If you want to write your own code, you can use GDAL and some QGIS tools in Python without the need of a GUI.


3

@AndreJ already mentioned GRASS, which is definitely avaliable in Ubuntu. The GRASS startup program has explecit options to start without a graphical user interface. From the manual page: grass74 [-h | -help | --help] [-v | --version] [-c | -c geofile | -c EPSG:code[:datum_trans]] [-text | -gtext | -gui] [[[<GISDBASE>/]<LOCATION_NAME>/] <...


2

Rebuilding postgis-2.2.2 from the source solved the problem, using the default build steps: ./configure make make install


2

I had this exact same problem with a small dataset (16 mil. points out of which GRASS was labeling as invalid about 30%). Luckily I also had another dataset that imported fine in GRASS so I compared them, and as wenzeslaus suggested, the only notable difference was that the second dataset had no scan angle information stored (i.e. all values were 0). This ...


2

I'm assuming you have installed some version of Postgresql on your machine. I recently used these command to install Postgresql and Postgis to run on my Ubuntu 14.04 terminal. You would just need to update the versions in the code. sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt trusty-pgdg main" >> /etc/apt/sources.list' sudo apt-get ...


2

UbuntuGis was never updated for 14.04. If you look in ubuntugis/ppa/ubuntu/dists, the last entry is for Saucy, not Trusty. Hence your failures.


2

As outlined by @underdark, the globe plugin which is shipped with QGIS 2.16 depends on osgEarth 2.7 which is not available out of the box on ubuntu 14.04. Your options are: Upgrade to yakkety yak or use xenial with ubuntugis unstable Stick to QGIS 2.14 Compile osgEarth and then QGIS (with globe enabled) yourself Directly from source (when compiling QGIS ...


2

It seems like you need Ubuntu Xenial to get Globe for 2.16. I got the following explanation on the QGIS mailing list by Jürgen: Globe is only include where osgearth 2.7 is available (ie. debian unstable has it, ubuntugis xenial has it IIRC). For 2.14 it's inverse, there globe is only available where osgearth<2.7 is available.


2

You should set your environment variable to the ubuntuGIS GDAL, as this will have the needed file support. You should have a PATH variable set to the correct GDAL. First check with the command which -a gdal-config where your GDAL versions are installed. The -a checks for several installations. There should be two in your case. Then check with echo $PATH if ...


2

The easiest way to get your preferred GDAL/Python version without the restrictions imposed by your system package manager is to use the conda package management system. You can use this without admin/root privileges as it installs to your home directory and you don't run the risk of messing up your system by installing a non-standard system python. Install ...


2

The ubuntugis ppa holds only LTR versions, currently QGIS 2.18.28, see https://launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable/?field.series_filter=bionic. If you want QGIS 3.4, you can take the https://qgis.org/ubuntu/ repository without any ubuntugis dependencies. You might have to remove any packages you have from ubuntugis before installing. ...


1

Problem solved! I had some wrong set paths for gdal and the wrong scipy version for python 2.7. I re-installed GDAL, set the paths correct and then downgraded scipy to version 0.17 (note that you downgrade scipy for the python version that is used by qgis, I thought the downgrade had no effect but in fact I've downgraded the scipy version for python 3.5)


1

A lot of processing in QGIS are "just" commandline tools in a nice gui. If you use a local QGIS to test your command, you could execute that command on the server via ssh. If the command is not a terminal command, it might be a Pyhton one. Generate the script localy and run it on the server, again via ssh.


1

This is strange approach. Usually to get QGIS like rendering Web maps people use NextGIS Web or QGIS Server. And for geoprocessing - WPS (for example pyWPS or ZOO project). For instance - try nextgis.com with NextGIS connect plugin. If this is what you need, you can install NextGIS Web on your server. Look at documentations here: http://docs.nextgis.com/...


1

Remove qgis.org/debian and ubuntugis from your sources. Update apt update Install QGIS (2.14 is in the 17.10 repos) apt install qgis If you want QGIS 2.18 (3.0 when it's released), install it via Anaconda. Install miniconda: wget https://repo.continuum.io/miniconda/Miniconda3-latest-Linux-x86_64.sh bash Miniconda3-latest-Linux-x86_64.sh Install QGIS ...


1

You can see what versions are available on the repository using apt-cache policy gdal-bin and then install a specific version using sudo apt-get install gdal-bin=1.11 UbuntuGIS has several versions available and can be added as a repository using sudo add-apt-repository ppa:ubuntugis/ppa


1

Until QGIS on the Ubuntugis repos gets built with the updated GDAL packages the easiest workaround I've found to get around this dependency issue is to create a fake virtual gdal-abi-2-1-2 package using equivs-build per the instructions here: Cannot install QGIS 2.18 from repository on Debian Stretch; package "gdal-abi-2-1-1" not installable QGIS ...


1

Following the instructions in the comment by pwes: You can also manually install python-future and python-owslib from http://packages.ubuntu.com/xenial/all/python-future/download and http://packages.ubuntu.com/xenial/all/python-owslib/download with dpkg, and then follow with upgrade. Note that those two packages will be left without updates (also ...


1

I am sorry everybody! I discovered the origin of the error, it was much simpler than than I originally thought. The problem was that the environment variable "GISBASE" in my bashrc file needed to be changed to "/usr/lib/grass72" so the system looks for grass in the correct folder.


1

The CLI version attempts to load the last-accessed database, location, and mapste. If that folder no longer exists, it gives an error. Try explicitly providing a database, location, and mapset: grass /path/to/DB/LOC/PERMANENT


Only top voted, non community-wiki answers of a minimum length are eligible