Hot answers tagged

1

WMS does not have attributes. In geoserver, wfs of the layer should be available too. Add wfs layer instead of wms.


1

This ended up working with XYZ tiles. I just put it in like this, https://s3.amazonaws.com/bucketname/key/b_{q}.png and it worked


1

Try specifying extent in the OpenLayers layer settings (it needs to be in view projection units regardless of the projection the WMS is using) new ol.layer.Image({ source: new ol.source.ImageWMS({ ... }), extent: [-180, -90, 180, 90] })


Only top voted, non community-wiki answers of a minimum length are eligible