0

Using the grass GUI I get this error message:

ERROR: G_calloc: unable to allocate 2004389888 * 8 bytes of memory at raster.c:71

What can i do to remedy this?

4
  • 1
    This is a request for about 14.9 GB of memory. Maybe you ran out of memory?
    – gene
    Jun 17, 2014 at 16:22
  • Tell us which operating system and which GRASS GIS version...
    – markusN
    Jun 19, 2014 at 19:03
  • using Grass 6.4.3 (standard installation with Qgis Vlamiera) for Windows
    – VeM
    Jun 22, 2014 at 8:48
  • I have opened a ticket for this: trac.osgeo.org/grass/ticket/2404
    – markusN
    Aug 27, 2014 at 19:58

1 Answer 1

1

To reduce the memory footprint of v.to.rast with large maps, set in v.to.rast the parameter:

rows=value

to a value much less than the default 4096.

1
  • Good news: the management of the memory has been improved in v.to.rast, now the amount of memory rather than rows can be specified.
    – markusN
    Sep 15, 2014 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.