1

I'm having trouble debugging my model that I'm creating in ArcMap 10.1 ModelBuilder.

The model is just a simple string of geoprocesses, but there's a point at which the model isn't exporting the expected features. Specifically, I've narrowed it down to a point at which the model takes a polyline file which had been erased (interim_erased) and intersects it with a selected polygon file (Inactive_ESA), and at this point the output file (interim_intersect) is empty.

The only thing I see that could be happening is that the "ESA" isn't getting selected at the "Select by Attributes" step (The output being "Inactive_ESA"), because the erased file "interim_erased" has the expected features in its table.

Also, I've double-checked the selection expression - it's correct and works fine outside of ModelBuilder. I also have the license to execute Erase.

Maybe, if someone knows how to look into ModelBuilder at what's actually getting selected at the "Select Layer By Attributes" point in the model?

part of the model process which has output a blank attribute table

++++++++++++ ADDED 2014-07-31 +++++++++++++++

The ESA polygons are broken down by active(green) and inactive(red), the polylines as well, active(green) and inactive(red). I'm selecting the green polygons in the ESA, and selecting the red polylines. Then I'm Erasing the red polylines with the green ESA. (This part works, and my intermediate data for this process outputs the expected result - red polylines only on the red ESA with no red polylines overlapping onto green ESA).

However, when this erased file of red polylines is intersected with my selected Inactive_ESA (which is where I'm selecting the red polygons), the table is empty. So this suggests to me that the ESA isn't actually getting selected by the "Select Layer By Attribute (9)" process. How might I see what's actually getting selected at this step? (because I've double checked my expression and it's correct and works fine outside of the model)

ESA and polylines included in the model

  • Make sure your select is set to "New Selection" ? – GISKid Jul 31 '14 at 14:10
  • Yup, checked that too. It is – geominded Jul 31 '14 at 14:49
1

Right click on Active_ESA, select Add to Display and rerun entire model

  • I think this only works for intermediate data, but I don't think it works for just a selection process. – geominded Jul 31 '14 at 14:08
1

Problem "solved". I just deleted the Select Layer By Attribute (9) and re-replaced it with a new Select Layer By Attribute process. When I revalidated and ran the model, the intersect worked, and everything looks like it's supposed to.

Maybe I don't get some fundamental thing about ModelBuilder, but it looks like the order you place tools on the whiteboard of ModelBuilder actually matters. Even though the connections were correct (and has exactly the same parameter as before I replaced the Select By Attribute tool), removing the Select by Attribute tool and replacing it worked for some reason.

  • Mind posting your finished model so we can see the difference? – GISKid Jul 31 '14 at 15:54
  • There was literally no difference. I just deleted and replaced the exact Select Layer by Attributes and copy-pasted my selection expressions that was in my original Select Layer by Attributes process. – geominded Jul 31 '14 at 21:57
1

So you've confirmed that the select layer by attribute is definitely selecting your polylines.

Well here is a list of potential problems:

  • Your polyline and erase layers are different coordinate systems
  • The erase layer has a selection on it so it never clips the area you expect?
  • The erase layer must be a polyline or polygon layer (i.e. higher geometry dimension)
  • The select by attribute (9) in your model is not selecting what you expect

Finally would it be the correct understanding of you model is that you have your ESA layer, select the active polyines, erase some of these, reselect the inactive polylines and then attempt an intersection of inactive lines in an area of nothing which should produce nothing...

So if I have understood your description and if everything was running as expected the black line that I have identified below based on image above would be what the intersect is returning?

Intersect result

  • I've added an image of ESA/polylines that I'm using in a place where the erase/intersect case applies. I'm guessing it's "The select by attribute (9) in the model is not selecting" problem. – geominded Jul 31 '14 at 14:56
  • the black line is what the ERASE is returning. The INTERSECT (the intersection of the erased polyline file and the red polygon) is what was returning nothing. I just replaced the Select Layer by Attributes process and it worked fine. I still have no idea what was causing the intersect to return nothing though. weird :/ – geominded Jul 31 '14 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.