8

When using ArcGIS while in layout mode, after a variable period of time having an open ArcGIS project, the mouse cursor will get stuck in "Auto-Pan" mode. No matter which tool I select from the toolbar, the cursor stays the same. If I hit the "C" or "Ctrl" key repeatedly, the cursor will assume its proper form and function, but revert to auto-pan the next time I change the tool.

This has persisted from 10.0-10.3 and multiple machines. The only way to fix it is to restart the machine. I get a brief respite, and the problem is back.

Does anyone have a solution to this problem?

11
  • 1
    Everyone in my organization is experiencing this same problem. Not sure what is causing it or how to fix it. It certainly is annoying though. If anyone has a solution I would also be curious!
    – crmackey
    Feb 13, 2015 at 17:30
  • Yes, same pb here (10.1) ! But I close ArcGis (don't forget arcCatalog) and open it again I don't have to restart CC
    – Claire C
    Feb 13, 2015 at 17:35
  • 1
    Have you contacted ESRI? Feb 13, 2015 at 18:14
  • 1
    I've edited your question to turn "Has anyone else had this problem?" - which invites "me too" answers of little value - into "Does anyone have a solution to this problem?" - which invites solutions.
    – PolyGeo
    Feb 15, 2015 at 6:11
  • 2
    Thread about it on Geonet. OP there said hitting the 'g' key worked but it didn't seem to help others.
    – mkennedy
    Mar 4, 2015 at 17:35

3 Answers 3

3

I have been having this issue, and as a short term solution:

  • make sure the cursor mode you would like to use is selected
  • press shift.

The shift command will switch the cursor to whatever you have selected. I find this has temporarily solved the issue for me. I only started having this problem with 10.3 so I am assuming it is a version error.

This is similar to your solution, but you only have to press shift once and it works every time.

3
  • I've found this to work as well, but as soon as the window or tool changes focus, its back!
    – dwight
    Nov 19, 2015 at 18:29
  • Hey, I've been having this issue since at least 10.1 Shit, "crtl" and "z" all sometimes work to temporarily solve the problem. However, when the issue rears its' head, some tools are unusable. Things like the measure tool require more than one click to operate, and if you hit the shift key or "c" key, it boots you out of the tool.
    – dwight
    Feb 14, 2017 at 16:33
  • I just found that this problem also exists in ArcGIS Pro, your solution also worked. Thanks.
    – PGerrits
    May 10, 2021 at 23:17
1

Same issue discussed on Esri's GeoNet forum https://community.esri.com/thread/53112?messageTarget=all&start=100&mode=comments

A common variable was the use of Webroot antivirus software. The response I recieved from Webroot was:

To help diagnose the issue you are experiencing, we would like you to try disabling the Identity Shield. Please follow the instructions below.

  1. Open Webroot SecureAnywhere.
  2. Open the "Identity Protection" menu on the right.
  3. Click the Identity Shield toggle so that the white status indicator is to the RIGHT.
  4. If prompted, complete the CAPTCHA and click "Enter."
  5. Test the issue you have been experiencing to see if it occurs when the Identity Shield is disabled.

Once you are done testing, we recommend you re-enable your Identity Shield now by repeating steps 1-4, changing the toggle to read "Identity Shield is On."

** If the issue STILL OCCURS when the Identity Shield is Off, please reply to this message to let us know and we will continue to troubleshoot. In this case, there is no need to complete any steps below this line.


** If the issue DOES NOT OCCUR when the Identity Shield is Off, please follow the steps below:

  1. Click the gear next to "Identity Protection" and then click on the "Application Protection" tab.
  2. Reply to this message to say that the issue DOES NOT OCCUR when the Identity Shield is Off. In your reply, be sure to include which items are listed in the Protected Applications window, and whether each item is set to Protect, Allow, or Deny.

I haven't had the issue come again so I cannot attest to the usefulness of the advice given.

1

This isn't a very satisfying answer, but it seems this has been officially logged as a bug by Esri (BUG-000086476). Apparently this is caused by certain antivirus software, and the official Esri recommendation is to "work with the antivirus vendor to determine the appropriate security settings to resolve interference with ArcGIS software."

Not the answer you're looking for? Browse other questions tagged or ask your own question.