1

I recently reinstalled PostGIS on my pc, following these instructions link.
The installation is successful, and for several days work using PostgreSQL and PostGIS without problems. Now, I need to insert some shapefile within my database, but trying to execute the command "shp2pgsql" I get this result:

abominio@abominio-X555LD:~$ shp2pgsql --help
Il programma "shp2pgsql" non è attualmente installato.
È possibile   installarlo digitando: sudo apt-get install postgis

I tried to do a search

sudo find / -name shp2pgsql

but I do not get results.
currently I'm using Postgres 9.3 and PostGIS 2.1.6. why I do not have this function? how can I fix?

  • I have the same problem. Could you solved it? – Overflow012 May 26 '15 at 22:12
1

You could try to make a link under /usr/bin/shp2postgres to ../lib/postgresql/9.3/bin/shp2pgsql with the right permission.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.