2

I am having trouble computing some service area polygons in ArcMap 10.2. It seems to work fine when calculating distance, but has problems when looking at time.

I have UK road data (Meridan 2), and am attempting to create drivetime polygons around a number of retail sites. For each road length Ihave assigned a speed (based on the type of road - ie major/minor and the settlement type - ie rural/suburban/urban) and calculated the time in seconds to travel along that length of the road. I have created polygons using 'make service area' in the network analyst tool. I first looking only at distance (metres), and this worked fine (see image). However, when I try to calculate service areas based on time (seconds), I get very odd results.

I have copied below the service areas that I get around 5 sites, with an impedance of either 5000 metres or 0.2 seconds (obviously I want a longer drivetime than that, but anything larger than this gives huge service areas - this is the problem).

As you can see, when calcuatingareas based on time, some of the sites have tiny service areas (which makes sense, given the small time available) but some (one in this example) have very large areas. Actually in this example two of the service areas are even rectangles, which is even more surprising and I hadn't noticed before.

All street lengths in my network seem to have positive integer values in the 'seconds' field. These values for seconds tend to be quite similar to the values for meters that are working fine (all my speeds are between 6 and 30 metres per second). Seconds is specified as a cost attribute in the network dataset properties for my network dataset (all_roads_speed_ND). I really don't know what's going on.

enter image description here

Service areas with distance

enter image description here

Service areas with time

  • There is a bug in ArcGIS 10.2 NA; try setting for default drive-time value in the NA layer settings to be larger than any value you have specified in the Attr_Impedance field. – Alex Tereshenkov Jun 23 '15 at 12:27
  • I'm not sure that helped. My longest road section is 1794 seconds, so I changed the default breaks in Service Area Layer Properties (analysis settings tab) to 2000 seconds (is this what you were suggesting?). This isn't that large a number, a little over half an hour, but the resulting polygon covered the whole of the UK. – greytape Jun 23 '15 at 12:47
  • That is correct. If this didn't help, then can you verify that you are actually using the seconds and not the minutes? Because you could cover the UK within 2000 minutes :) – Alex Tereshenkov Jun 23 '15 at 12:52
  • That was one of my thoughts too, but I'm pretty certain that I am using seconds. I have Layer properties -> Analysis Settings -> Impedance set as "Seconds (Seconds)" (Seconds is the name of the relevant column in my attribute table). In Network Dataset Properties -> Attributes I have Seconds listed as a cost attribute using the Unit 'seconds'. – greytape Jun 23 '15 at 12:59
  • Many thanks for your help here Alex. Turns out I was being stupid and not all of the road lengths had values for 'Seconds' (seems there was a problem when I generated these values in QGIS). Following your advice made me realise this, and seems to be all sorted now. – greytape Jun 24 '15 at 13:47
0

There is a great chance something is wrong with your cost field.

I'd create a new field and calculate it to contain the seconds and then re-build the network dataset supplying this field as a cost field and choosing seconds (you might consider using minutes as it is nicer to see 5 min instead of 300 secs).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.