When running cmake for CGAL 3.9, I get the following output:

root@postgresql local/CGAL-3.9# cmake -DWITH_CGAL_Qt3=OFF -DWITH_CGAL_Qt4=OFF -DWITH_CGAL_ImageIO=OFF .
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Build CGAL from release: CGAL-3.9
-- Packagenames: CGAL-3.9
-- CGAL_SOVERSION     =8.0.0
-- Building shared libraries
-- Targetting Unix Makefiles
-- Using /usr/bin/c++ compiler.
-- USING CMake version: 2.8.0
-- System: Linux
-- USING GCC_VERSION = '4.4.3'
-- Using gcc version 4 or later. Adding -frounding-math
-- Build type: Release
-- USING CXXFLAGS = ' -frounding-math -O3 -DNDEBUG'
-- Could NOT find GMP
-- Could NOT find MPFR
-- CGAL_Core needs GMP, cannot be configured.
CMake Error at cmake/modules/FindBoost.cmake:917 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.40.0

  Boost include path: /usr/include

  The following Boost libraries could not be found:


  No Boost libraries were found.  You may need to set Boost_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
Call Stack (most recent call first):
  cmake/modules/CGAL_SetupBoost.cmake:12 (find_package)
  cmake/modules/CGAL_SetupDependencies.cmake:32 (include)
  CMakeLists.txt:422 (include)

-- Boost include:     /usr/include
-- Boost libraries:
-- Boost definitions:

I've tried various env variables. I am wondering if I need to install / compile some other boost thing? I have some libboost* in /usr/lib Any suggestions on things to try would be appreciated.

  • If the instructions you for installing lib-boost-xyz did the rtrick, pelase accept it as an answer
    – fmark
    Oct 4 '11 at 4:48
  • It will not solve your problem, but never run cmake (or make) as root. It may cause unexpected problems, and is a bad practice anyway.
    – johanvdw
    Oct 4 '11 at 6:34

JJ- thanks for the input. I was digging around in those .cmake files last night. I should have mentioned that overtired = overlooked.

in the many apt-get commands i ran, i ran the following:

apt-get install libboost1.40-dev
apt-get install libboost-thread1.40.0

I then decided to try:

apt-get install libboost-thread-dev

Then for good measure, rebooted. Now its getting past THAT issue. On to the next one!

  • No need to reboot. And if you build a package from source you always need *-dev packages.
    – johanvdw
    Oct 4 '11 at 6:37

I spent quite sometime to build cgal a while ago. I don't remember the details anymore, but below is some of my notes. Hope it can help you. I was using boost 1.47. Obviously, I had the same problem as you have now, and it definitely is fixable. -JJ


cmake -G "MSYS MakeFiles" modify the CMakeCache.txt, set the boost include directory, which would be in the local/include of msys May also need to modify Cmake/modules/FindBoost.cmake, if you have trouble finding boost_thread library I also set the env variable: BOOST_LIBRARYDIR=D:/pgroute/MinGW/msys/1.0/local/lib Also modify the FindBoost.cmake, added 1.47 and 1.47.0 to the version list make

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.