7

I have a problem with ArcSDE that I have never come accross before and I was wondering if anyone could shed any light on this problem.

Problem ArcSDE 9.3.1:

Connnecting to an ArcSDE instance (Oracle Spatial) with over 20,000 datasets (raster) causes ArcGIS/ArcObjects code to connect very slowly - minutes in fact before a successful connection is made to the database. However if a native SQL connection is made, the connection is almost instant.

Has anyone else had this problem and if so what can be done to remedy this problem.

5
  • Are you storing your rasters in a Raster Catalog? Oct 18, 2011 at 14:37
  • Probably a better description of the connection strings and particulars of the keyword datatype would be beneficial.
    – Brad Nesom
    Oct 18, 2011 at 14:45
  • Not sure until I get to the client site - but I'm guessing they are just plain loaded into ArcSDE without any configuration.
    – Vidar
    Oct 18, 2011 at 14:58
  • I will get back to you with more details when I get to the client site too...maybe I was jumping the gun a bit too much here :)
    – Vidar
    Oct 18, 2011 at 15:17
  • Actually, I remember, they are loaded into the database as blobs - so each tile is a blob, I don't think they use raster catalogs at all.
    – Vidar
    Oct 18, 2011 at 15:27

2 Answers 2

4

Are they registered with the GeoDatabase and in A Raster Catalog? If not, it basically has to dynamically find info about each table and 20,000 DB DESCRIBEs can get kind of heavy and time consuming :)

1
  • ahh interesting. This has given me some things to think about - hopefully it should be a fairly easy fix.
    – Vidar
    Oct 18, 2011 at 19:50
0

We had a noticeable speed improvement when we switched our users over to Direct Connections.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .