2

I am using FME 2014 in order to manipulate some shape files. When I load and inspect the content of the shapes file, I get the following problem:

Although all the greek characters of the content is shown correctly (in UTF-8), the titles of each column (seeing in data inspector) are not recognized. A similar problem I had some time ago with an excel file which had content in greek. In that case also I could see the content of the excel cells but I could see the names of the tabs (sheets). Back then it was enough to rename the sheets to latin characters but now I don't have this luxury (some hundreds of shape files).

What is the issue here? Is there some internal encoding properties in FME? I see I have the same problem in FME 2015.

2

Load your shapefile into Workbench and go to the advanced setting and select Character Encoding and change to UTF-8

Here is a quick example using FME Desktop 2015.1.2

enter image description here

  • Thanks for the answer. This actually doesn't solve the problem. I tried it but the encoding is already set to utf-8. Actually this is the same parameter I set when I import the shape file. – user1919 Sep 25 '15 at 6:18
  • The problem is even greater than the above mention. I try to import a shapefile with greek characters and FME can not read it correctly. In the directory field it shows question marks instead of greek characters and its impossible to load it! – user1919 Sep 25 '15 at 7:10
  • is the shapefile publicly available? It is hard to diagnose without the source file you can submit (workspaces/data) to knowledge.safe.com/knowledgeSubmitCase and they can help – Mapperz Sep 25 '15 at 14:01
1

I have contacted FME support and this is their answer:

"Thank you for contacting Safe Software's support group. Unfortunately this is a known issue for Shape files created with ArcGIS."

As a workaround I used the transformer: AttributeRenamer. Its a bit of a manual work but if you do it once and all your shape files have the same naming then you are fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.