8

I am attempting to import a Shapefile into QGIS. When I import it, the boundary is shown on the list, but when I try to view it in the mapping area, it does not show up.

I can get it to show the nodes if I go into edit mode, so I know the data is there. I've have the same problem in v2.8.2 and v2.12.3. I can run some of the polygon tools from the tool box such as SAGA Polygon properties, and it will then show the polygon when the new layer is created.

I am able to load these same polygons into another program and they work properly. I've saved the files to my Google Drive and it can be linked below.

Anyone have any idea what I might be doing wrong. I've gotten other shapefiles to show in QGIS with no real issues previously. I'm very new to QGIS.

link to Boundary data Shape Data

  • ArcGIS reports: bad envelope, bad dataset extent (twice), and could not find spatial index. I tried Repair Geometry tool on it, but still couldn't see the polygon. – mkennedy Mar 1 '16 at 21:06
  • I attempted the Repair Geometry as well and was unsuccessful. I also ran the Check Geometry Validity tool and it did not show me any errors like the ArcGIS report. Thank for looking at it. – Jason Steffen Mar 1 '16 at 21:15
  • That is an interesting shapefile. OpenJUMP can open it and the only error that the QA tool finds is two same consecutive points in one location. However, if I convert your shapefile into a new one with ogr2ogr, the new shapefile still has the consecutive same points but QGIS does open it. There is some problem with extents: ogrinfo from the original Extent: (0.000000, 0.000000) - (33.036383, 33.036383), from the corrected Extent: (-115.675374, 33.030347) - (-115.671647, 33.036383). As said, you can correct the data with ogr2ogr. – user30184 Mar 1 '16 at 21:33
  • I agree with the Extent error. I noticed that as well that when I Zoom to Full when selecting only data that was within the boundary, it would zoom to where it was suppose to. However when I did the same with the boundary, it would zoom out and use the 0.00000, 0.00000 location. – Jason Steffen Mar 2 '16 at 16:40
  • I am a bit weak on Shape File formats, how does QGIS determine the Extents when it imports a file? Is it possible it is reading it wrong? Is there a problem with the Shape file itself in that it is not formatted properly? I seem to only have this problem with files coming from a specific software source so I suspect they may not be doing something correctly when they generate it. – Jason Steffen Mar 2 '16 at 16:40
4

I saw the same thing. I was able to view it in QGIS with a bit of geometry fixing.

If you run Vector > Geometry Tools > Check Geometries, and write the corrected geometry to a new shapefile with the Output Vector Layer options, you get this...

enter image description here

This is core functionality but was only added fairly recently (2.12, I think) so it's worth checking if you have this available. I did this on 2.14.0 Essen.

EDIT

It turns out you need to manually install this plugin, it's not in core (I saw it was implemented as an .so - the Linux equivalent of a .dll, and wrongly assumed it was part of QGIS... just means it was done in C++)

You can find it in the Plugins manager under Geometry Checker. According to this blog post the fixing functionality was added in 2.12.

  • I don't see the Output Vector Layer option in QGIS 2.12.3 so perhaps only available in 2.14? – Joseph Mar 2 '16 at 10:30
  • I didn't see that option either. I did see the Check Geometry Validity tool. I ran that and it showed no errors in the list. However, when I ran the tool and told it to save error locations, then it saved an error showing the duplicate same points. Why does the error show up in one part of the tool and not the other? That a bug? – Jason Steffen Mar 2 '16 at 16:28
  • 2
    @Joseph - I don't remember having to install this plugin, but I may be wrong.. it appears in the Plugins list as "Geometry Checker". According to this blog post the ability to fix the geometries arrived in 2.12. Before that you could only list problems, not fix them. – Steven Kay Mar 2 '16 at 20:20
  • Thanks. I found the plugin and it worked as you say. At least I can use the data now. – Jason Steffen Mar 2 '16 at 23:25
  • 1
    @StevenKay - My apologies, you are indeed correct =) – Joseph Mar 3 '16 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.