0

I try Mapserver 5.6.4 on Linux.

I've compiled Mapserver ,then put it on /cgi-bin/ direcotry. I tried to access "http://localhost/cgi-bin/mapserv", but "500: Internal Server Error" was shown.

I saw error point, and I guessed that msEvalRegex() didn't work. So I commented out mapfile.c codes of between 5190 lines and 5202 lines. ( if(getenv("MS_MAPFILE_PATTERN")....)

Then, mapserver worked well. (I got a response "200") I don't know the reason. (Mapserver needs any other library??) Please tell me about it.

My english is very poor, sorry.

  • Try first with a newer version v. 7.0 or at least 6.4. – user30184 Mar 28 '16 at 14:21
  • I tried version 6.4.3. The same problem occuered. – yu-taka Mar 29 '16 at 1:23
1

The mapserv binary created needs to have —rwxr-xr-x permissions to be able to execute so if needed you can change permissions using:

#chmod 755 mapserv

To test you have compiled mapserv with all appropriate options you can check the version:

#./mapserv —v

you should get an output like:

MapServer version 5.6.4 OUTPUT=GIF OUTPUT=PNG OUTPUT=JPEG OUTPUT=WBMP OUTPUT=PDF OUTPUT=SVG SUPPORTS=PROJ SUPPORTS=AGG SUPPORTS=FREETYPE SUPPORTS=ICONV SUPPORTS=FRIBIDI SUPPORTS=WMS_SERVER SUPPORTS=WMS_CLIENT SUPPORTS=WFS_SERVER SUPPORTS=WFS_CLIENT SUPPORTS=WCS_SERVER SUPPORTS=SOS_SERVER SUPPORTS=THREADS SUPPORTS=GEOS SUPPORTS=RGBA_PNG INPUT=EPPL7 INPUT=POSTGIS INPUT=OGR INPUT=GDAL INPUT=SHAPEFILE

If you get an output like this, then you know that MapServer is compiled correctly for your system; then you can move on to configuring the web service.

  • The mapserver I complied showed one's version like what you said. And that is the same on 6.4.3 version. – yu-taka Mar 29 '16 at 1:30
  • Apache's log showed "*** glibc detected *** free(): invalid next size (fast):" This infomation help to find problems? – yu-taka Mar 29 '16 at 2:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.