1

I would like to export a georeferenced tif from QGIS composer. I am using QGIS 2.16.1 with windows 7 (32 bit).

In the composer export settings I have selected "Print as raster" and "Save World File". I am using an export resolution of 96 dpi and an A4 page size. When I use "Export as image" and use file formats including jpg, tif, tiff and bmp I obtain excellent raster images without a corresponding world file. The QGIS documentation states that the "Exporting big rasters can sometimes fail, ..." but does not qualify what big means, or, what is meant by "fail".

In my situation a suitable raster is generated, but, it is missing the associated world file. My data is a topographic map containing vector layers only. Although the generated image file is not accompanied by a world file, it contains the suitable "Layer Spatial Reference System" property, but is missing the "Pixel Size" and "Origin" properties. From the same QGIS project file and the same "print composer" QGIS 2.14.3 outputs an image file that contains the suitable "Pixel Size" and "Origin" properties.

  • All vector layers have coordinate systems defined (right click layer - properties)? – BERA Aug 10 '16 at 8:31
  • Is it perhaps a geoTiff? Try adding it back into QGIS and see if it is the correct place. – HeikkiVesanto Aug 10 '16 at 9:01
  • As the same procedure using QGIS 2.14.3 on the same project file works I assume that the vector layers have the coordinate system defined. – Philip Whitten Aug 11 '16 at 1:47
  • It does appear that QGIS 2.16.1 now incorporates the coordinate reference system information within the file like a geoTiff, and no longer includes a separate world file which QGIS 2.14.3 did. However, the output geoTiff is missing the "Pixel Size" and "Origin" properties. – Philip Whitten Aug 11 '16 at 1:49
0

I have the same problem using 2.16.0 64 bit and Windows.

I tried with 2.14.3, and then it works (I tried .jpeg and .tiff, both produced world files).

  • I have compared the output of versions 2.16.1 and 2.14.3 from the same "print composer" for the same QGIS project file. The tiff output from version 2.16.1 contain the appropriate "Layer Spatial Reference System", but, it does not contain any values for "Origin" or "Pixel Size". – Philip Whitten Aug 11 '16 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.