1

I have a field within a feature class that I had assigned a coded text domain to, but then created a different coded text domain with updated information that I then pointed to as my new domain instead.

The new coded domain works fine for editing data and shows no sign of the original domain, but when I go to delete my old domain I no longer use from the file geodatabase it tells me 'domain is used as default domain'. I get this error whether I go through the domain options within the feature class in ArcCatalog or through the delete domain tool in ArcToolbox/Data Management/Domains.

ESRI File geodatabase was created and is being edited in Arc 10.0. on the same machine by the same user.

How would I go about removing this domain error or do I need to duplicate the FGDB and hope it removed any corrupted files?

  • Does your feature class use subtypes? make sure your new domain is configured with each subtype in the feature class? Are you sure it is not being used in a different feature class as well? – Ben S Nadler Sep 21 '16 at 20:35
  • It's not being used with any other feature classes and sub types aren't being used – GIS_Tech Sep 22 '16 at 17:22
  • You could try duplicating the feature class by creating a new empty feature class with the same schema(not using copy/paste), load the features into it, then delete the original feature class. Then try to delete the domain. – Ben S Nadler Sep 23 '16 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.