1

I have a large project with provincial data. The project is currently using a data driven map with a clipped data frame for the province. The issue is the data I'm trying to show is thousands of point labels within each province, and the now clipped border is clipping labels as well. How do I stop the labels from being clipped along with the data frame?

Also, I only want to show labels that are applicable to that specific province and not the neighbouring provinces.

  • Will data driven pages definition query work? – FelixIP Jun 10 '16 at 4:39
  • I suspect this won't be a data driven pages issue. Although you are seeing it there what you will need to be able to do first is to view labels outside the extent of a clipped data frame. Once you can do that you should just retest with data driven pages enabled. I am pretty sure that you will find at least one Q&A on that here. The extra question in the last paragraph should be researched/asked separately and I think there are Q&As for that here too. For that one page definition queries are the solution. – PolyGeo Sep 30 '16 at 5:55
  • Thanks, I tried setting my point infomation to being excluded by the clip, however then I end up with all the neighboring info showing as well. this makes the map look rather messy and eligible. I have looked for Q&As regarding this but no luck yet. Thanks again – Stefan Bosman Sep 30 '16 at 6:00
  • It sounds like page definition queries with that option (which I did not recall) should do it then. If not, use the edit button beneath you question to provide more details about what you tried and where you got stuck. Make sure to take the 2-minute Tour that is designed to introduce all users to the site's protocols. – PolyGeo Sep 30 '16 at 6:03
  • Ok thanks, I looked into page definitions which then worked. Learn something new everyday! Just set it to match the data driven page and als set the Point feature to ignore boundary data frame clip. THANKS!!! – Stefan Bosman Sep 30 '16 at 6:13
2

if you create a duplicate of the layer you are labelling, and use this as your "for label" version of the layer. Then turn off labels on the original. Then you should be able to exclude the "for label" layer by ticking it using the the Exclude Layers... button. This button is below the Clip Options drop down within the data frame properties.

  • This would show the labels for all the polygons regardless of whether or not they intersect with the current extent of the data driven page. – JMVDA Jun 9 '16 at 19:07
  • I'm dealing with this issue again (and couldn't figure out how to edit my above comment). The above solution would work with the combination of setting the "for label" to match the current ddp under Page Definition – JMVDA Oct 30 '18 at 13:28
1

To solve this I used a Page Definition Query to match the Data Driven Page and also set the Point feature to ignore the boundary for the dataframe clip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.