2

I have a point layer (green points) and a polygon layer (orange line) which a number of the points fall within.

I have double checked and both layers are in the same CRS.

enter image description here

I have tried multiple functions in the normal 'select by location tool', within, intersect etc but the tool runs and returns no selection.

I have also downloaded the 'Select Within' plugin. This also does not work giving me the error below.

enter image description here

I am at a loss as to why the select by location tool returns no results and also do not understand the error generated by the 'Select Within' plugin.

3

Both the standard tool and the plugin iterate over all features in the input layers. From the error, "AttributeError: 'NoneType'" is pointing to one or more of your features not having geometries.

Try zooming to the layer extent, selecting all visible features and delete features that aren't selected (have no geometries).

  • I have checked my data and you where correct there were some instances of data that did not have a location. I deleted that, re-saved the shapefile and have re-run both the select by location and select within functions. Select by location still returns no data, however now the select within tool does not have any errors, but it still selects no data. – Ben Mar 23 '17 at 1:17
  • 1
    I have re-imported the data from csv deleting the points within z,y data before even importing and the select has worked. Not sure why the delete in qgis didn't solve the issue but thank you for the solution. – Ben Mar 23 '17 at 1:30
  • 1
    I was going to suggest reimporting the csv as an alternative. You are right in thinking that your first attempt should have worked, but glad to see the later worked for you. – BlueTalon Mar 23 '17 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.