0

I'm attempting to determine land surface temperature from Landsat 5 in ArcMap 10.2.2. I created a model to generate land surface temperature. The model works correctly when I run any single landsat scene (date) through the model. When I batch the model with more than one scene I get outputs that are the same to the hundredths place, and which are different than if I ran the scenes individually through the model. The temperature ranges are still reasonable, but they are wrong. If I run ~30 scenes at the same time through the model I get an error about the model trying to access a virtual object. This always causes ArcMap to crash.

I can run the model with each of my scenes one at a time, but I have dozens of scenes I need to process. Is it a quirk of ArcMap that the model runs correctly with one scene and then acts progressively stranger with more scenes added, or is there some setting that I'm missing somewhere?

  • What if you use a raster iterator inside your model, instead of the batch mode? – GISGe Apr 13 '17 at 8:41
  • Thanks for the advice- I hadn't considered that. I'll give it a try. – user5858 Apr 14 '17 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.