1

Since a couple of days, I get this error in my Windows Geoserver 2.10 installation:

Could not open JDBC Connection for transaction; nested exception is org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Unique index or primary key violation: PRIMARY_KEY_B ON PUBLIC.TILEPAGE(KEY); SQL statement: CREATE PRIMARY KEY ON PUBLIC.TILEPAGE(KEY) [23001-119])

Has anyone an idea how to solve this?

  • I get this same error. Has anybody been able to resolve this? Windows Server 2012 with GeoServer 2.11.0 This same error is displayed on the "GeoServer: Disk Quota" site. And in the geoserver.log ERROR [geoserver.gwc] - Failed to get a quota store, the GeoWebCache disk quota subsystem will stop working now org.springframework.transaction.CannotCreateTransactionException: – Paul F Jun 11 '18 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.