1

I have been testing the functionality of GeoServer as a WMS raster server and I have noticed that the quality of the tiles at high zoom levels is low. Here is an example of the GeoServer tile vs the original.

GeoServer Tile:

GeoServer Tile

Original:

Original Tif

The single pixels need to be view-able for my intended purpose. I thought it might have been due to the png compression so I set that to 0, which did not fix the problem. I created overviews, which improved the visuals at lower zoom levels but the degradation was still present at high zoom levels. I set the interpolation method to bilinear from nearest neighbor which made no difference. I also tried using the GeoWebCache to pre-cache the tiles and this didn't help either. I used the default EPSG:4326 gridset. Does anyone know the reason for my problem and how I can fix it?

  • Can you verify that the first image is rendered like that 1:1 by GeoServer and not getting upscaled by your WMS client (GIS or browser)? What tool(s) did you use to get images from the WMS? – bugmenot123 Apr 10 '18 at 13:55
2

This is not a full answer but I want to give feedback on the great steps and guesses you have taken so far. I hope to update it with "the answer" once we cleared some stuff in comments.

I thought it might have been due to the png compression so I set that to 0, which did not fix the problem.

PNG compression is lossless so there can not be any visual artifacts due to this.

I created overviews, which improved the visuals at lower zoom levels but the degradation was still present at high zoom levels.

Overviews are meant for performance improvements (pre-rendering parts so they can be served quickly). That you got better visuals would be dependant on the resampling used.

I set the interpolation method to bilinear from nearest neighbor which made no difference.

If you want pixels, you want nearest neighbor. Anything else will lead to mushy results like in your "bad" screenshot.

I also tried using the GeoWebCache to pre-cache the tiles and this didn't help either.

That just pre-renders the tiles. The results are the same visually regardless of when they were rendered.

I used the default EPSG:4326 gridset.

That should not be relevant for this problem. You are dealing with artifacts due to resampling on a >1:1 scale.

  • 1
    it was the inteporation method. I had set it to nearest neighbor in the layer configuration settings and not in the WMS settings, which was the problem. Thank you for the help. – Trashmonk Apr 10 '18 at 14:07
  • Sweet! Glad to help :) – bugmenot123 Apr 10 '18 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.