1

I am currently conducting a LUCA review on address points within our locality for the decennial census review. The software provided is called GUPS; however, it is QGIS based with custom plugins. I have never used QGIS, but there is apparently a spatial query functionality that would be helpful for my analysis. I have checked that the plugin is installed in GUPS, but when I attempt to run the query via Vector -> Spatial Query, there is no option to actually run the query. Has anyone else experienced this issue?

  • Perhaps if you include screenshot of your issue, someone will be able to help. – csk Jun 7 '18 at 18:52
  • Thank you for your suggestion, which I very much appreciate, but I am hesitant to include a screenshot as the data involved is is protected by Title 13, and cannot be shared in any form. – Robin Jun 8 '18 at 19:40
  • Can you attempt to run the same or similar spatial query on unprotected data, and include a screenshot of that? – csk Jun 12 '18 at 1:45
1

I received a call back from the US Census Bureau regarding this inquiry and am posting the results of the discussion I had with a GUPS tech in case anyone else is hoping to use the spatial query tool for their LUCA review.

Per my conversation with a GUPS Tier 2 tech: the spatial query tool that is usually available as a standard plug-in with the QGIS software has been disabled for use in the GUPS version of the software and thus cannot be used to compare the Census address list to the user imported address list from within the GUPS program. The only reason given for disabling the spatial query plug-in was to direct reviewers to manually conduct the data review rather than automating the process. Unfortunately, the tech did not know of a way to re-enable the spatial query plug in from within GUPS as it was intentionally disabled.

For anyone looking for alternative methods to conduct the analysis, I was able to bring the census address list .csv (provided to localities with LUCA review materials) into ArcMap and geocode the address points. From there, I ran a spatial selection from within ArcMap against our user maintained address list. While the process worked, it did not return the expected results. As both datasets were point files, corresponding address points that did not match EXACTLY were not selected. I believe the most likely reason for for the mismatch is either due to the census recommended geocoding method and/or differences in projected coordinate systems as all corresponding address points were close but not exact location matches. I tried re-running the spatial selection with both a 10ft and 50ft tolerance, but the resulting numbers were still lower than expected. Basically, I wasted a lot of time trying to find a work-around and was unsuccessful, so I will be continuing in GUPS via the manual review process. Hopefully this at least saves someone else some time in figuring out that the spatial query plug-in is intentionally disabled in GUPS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.