1

This question has appeared in some random threads (https://community.esri.com/thread/217461-field-added-on-arcgis-online-does-not-appear-on-collector) with no clear solution.

Basic premise:

  • Simple collector setup with one KML file (two small polygons, hosted feature layer)
  • Initially 8 fields that required answering
  • I have full permissions over the groups/settings
  • Maps can be used offline and are working properly

The problem:

I needed to add 3 more fields to the questionnaire, which I successfully added via ArcGIS online. However, these fields are not showing up on the collector application. Moreover, the fields are not selected as 'on' when viewing the online map, and ticking them 'on' does not persist when closing and re-opening the online map.

Attempted solutions:

  • Removed and re-downloaded collector survey

Is there a setting/step I am missing?

1

Couple things I would recommend doing - Update the popup in the web map to have those fields as visible and editable. Also click Save to layer after making those changes as well so the feature layer item and web map have those changes - Refresh the map list in Collector. iOS pull to refresh, Android has that option on the overflow menu.

Then re-download the map.

  • Thanks for your response! I have tried all of the above but to no avail. Oddly, adding the fields via the web map rather than the ArcGIS online menu solved the problem. Any insight as to why? – Reputable Misnomer Sep 26 '18 at 13:38
  • Not sure why that would change.. I would check the popup info in the web map JSON in the case if was not showing up. Also did you remove the replica/offline data before you did the refresh map list. – Russ Roberts Sep 26 '18 at 13:40
  • Yes I did remove and refresh - quite odd! – Reputable Misnomer Sep 26 '18 at 20:10
-1

Check out this answer I found on this topic: https://community.esri.com/thread/209503-how-do-you-get-newly-added-fields-to-show-up-in-the-edit-widget#comment-805674

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Please check out our short tour to learn about our focussed Q&A format. This is what we call a link-only answer. It is fine to link to other sites but at least a summary of what is to be found by following should be included within your answer. – PolyGeo Nov 12 '18 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.