2

As far as I can see the up to date version of OpenLayers is 5.2. I am trying to connect my OpenLayers to my WPS but I have no luck doing so. All the info I can get says that there was WPS support in version 2 but "now" (old sources) in version 3 it wasn't implemented. I can't find any sources on how this is in the current version...

All I tried did not succeed so I got the feeling that trying to connect to my WPS like I would do in version 2 won't work at all. Before I continue to try to connect OpenLayers and my WPS I would like to have this question clarified.

So code like this won't work or I am using it wrong?

// Create a WPSClient instance for use with the local GeoServer
this.wpsClient = new OpenLayers.WPSClient({
    servers: {
        local: '/geoserver/wps'
    }
});
  • nobody has some answers for me? – Leo.1906 Oct 10 '18 at 9:11
  • Quiet a few OGC service features were lost in OpenLayers > 2, so it's quite probable that your research is correct. – nmtoken Nov 13 '18 at 15:06
1

The client itself like in the version 2 does not exist in Openlayers > 2. One has to build the XML file inside the Javascript and then post it to the WPS server.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.