2

I am using QGIS 2.18.26.

I have problems with a layer disappearing on map in my composer. First I thought it is a scale based visibility problem, it is a layer with some rectangles and titles on them on a map, visibility is setup to maximum 9 000 000 and minimum 55 000. Playing around with the scale based visibility made the layer appear sometimes but not in any logical way. Then I noticed that clicking of the scale based visibility setting does not seem to help, the layer is still hidden.

The rectangles does not show up. Never when generating an export / pdf / atlas, sometimes though but not often on the print composer screen before generating.

I have tried many different settings, and cannot see any logics in when the layer is shown and when it is not.

Does this ring any bells, any similar situations which have found a solution?

The layer is a locally stored shape layer with rectangles, 12 of them, covering the whole map (rectangles that show the atlas pages on a minimap on the side of each atlas page/big map). The layer is using the same projection as all other layers in the project. AND the rectangles sometimes appear, only to disappear a bit later. The rectangles / the layer in question can be seen in qqis main view as this: imgur.com/3GrMKzK . But in the print composer, no rectangle layer shown: imgur.com/Z1f05fC . No scaled based visibility check-marked now.

  • 1
    Could you be more precise about which kind of layer you are trying display? Is it a vector or a raster layer? Is it a local resource or a web service? Are the CRS of the layer and the project matching? Screenshots? – MarHoff Dec 14 '18 at 10:17
  • The layer is a locally stored shape layer with rectangles, 12 of them, covering the whole map (rectangles that show the atlas pages on a minimap on the side of each atlas page/big map). The layer is using the same projection as all other layers in the project. AND the rectangles sometimes appear, only to disappear a bit later. The rectangles / the layer in question can be seen in qqis main view as this: imgur.com/3GrMKzK . But in the print composer, no rectangle layer shown: imgur.com/Z1f05fC . No scaled based visibility check-marked now. – Benjamin Donner Dec 14 '18 at 13:09
  • Have you tried changing the symbology to see if they would show? Trying a fill would be a rough start, and if that shows you might try changing the outline thickness, perhaps by changing the units the thickness is measured in to map units to provide some consistency across different scales. – johns Dec 14 '18 at 13:24
  • Is it possible the map is just not showing the extent correctly? There is a button in the 'item properties' panel 'set to map canvas extent' - that should pan the map to what you're seeing in the main QGIS window. As long as your scale is within your ranges, you should see your polygons. – DPSSpatial Dec 17 '18 at 17:20
0

This problem was solved by updating to the next version of QGIS. What caused the problem still unclear.

  • It can also be the power of your computer. I noticed my laptop does not export everything in some projects, while my tower workstation does. Same QGIS version, same project, same settings. Especially large or complex layers are affected. – MrXsquared Jul 20 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.