0

I use GeoServer printing module (based on MapFish) to print my preview map in my application (uses Mapstore app).

My problem is that my WMS service is not in my PDF.

What I want, is to log outgoing request to know what MapFish doing with my service and layers.

For example, this is my JSON request var send to printing

{
    "units": "m",
    "srs": "EPSG:4326",
    "layout": "A4_no_legend",
    "dpi": 300,
    "outputFormat": "pdf",
    "outputFilename": "snapshot-map",
    "geodetic": true,
    "mapTitle": "",
    "comment": "",
    "layers": [
        {
            "baseURL": "https://server.arcgisonline.com/ArcGIS/rest/services/World_Imagery/MapServer/tile/",
            "opacity": 1,
            "singleTile": false,
            "type": "XYZ",
            "maxExtent": [
                -20037508.3392,
                -20037508.3392,
                20037508.3392,
                20037508.3392
            ],
            "tileSize": [
                256,
                256
            ],
            "extension": "png",
            "resolutions": [
                156543.03390625,
                78271.516953125,
                39135.7584765625,
                19567.87923828125,
                9783.939619140625,
                4891.9698095703125,
                2445.9849047851562,
                1222.9924523925781,
                611.4962261962891,
                305.74811309814453,
                152.87405654907226,
                76.43702827453613,
                38.218514137268066,
                19.109257068634033,
                9.554628534317017,
                4.777314267158508,
                2.388657133579254,
                1.194328566789627,
                0.5971642833948135
            ],
            "path_format": "/${z}/${y}/${x}"
        },
        {
            "baseURL": "http://server.arcgisonline.com/ArcGIS/rest/services/Reference/World_Boundaries_and_Places/MapServer/tile/",
            "opacity": 1,
            "singleTile": false,
            "type": "XYZ",
            "maxExtent": [
                -20037508.3392,
                -20037508.3392,
                20037508.3392,
                20037508.3392
            ],
            "tileSize": [
                256,
                256
            ],
            "extension": "png",
            "resolutions": [
                156543.03390625,
                78271.516953125,
                39135.7584765625,
                19567.87923828125,
                9783.939619140625,
                4891.9698095703125,
                2445.9849047851562,
                1222.9924523925781,
                611.4962261962891,
                305.74811309814453,
                152.87405654907226,
                76.43702827453613,
                38.218514137268066,
                19.109257068634033,
                9.554628534317017,
                4.777314267158508,
                2.388657133579254,
                1.194328566789627,
                0.5971642833948135
            ],
            "path_format": "/${z}/${y}/${x}"
        },
        {
            "baseURL": "MY_DOMAIN/geoserver/wms?",
            "version": "1.3.0",
            "opacity": 1,
            "singleTile": true,
            "type": "WMS",
            "layers": [
                "LAYER_NAME"
            ],
            "format": "image/png",
            "styles": [
                ""
            ],
            "customParams": {
                "bbox": "-10,10,35,50",
                "TRANSPARENT": true,
                "TILED": true,
                "EXCEPTIONS": "application/vnd.ogc.se_inimage",
                "scaleMethod": "accurate",
                "CRS": "EPSG:4326",
                "SRS": "EPSG:4326"
            }
        }
    ],
    "pages": [
        {
            "center": [
                30.108827,
                60.205444
            ],
            "scale": 3000,
            "rotation": 0
        }
    ]
}

And I don't how MapFish uses it.

I think it create request like this: https://MY_DOMAIN/geoserver/wms?BBOX=XXX&WIDTH=3250&HEIGHT=871&format_options=dpi%3A300&map_resolution=300&CRS=EPSG%3A4326&FORMAT=image%2Fpng&bbox=XXXX&STYLES=&LAYERS=XXX&EXCEPTIONS=application%2Fvnd.ogc.se_inimage&TILED=true&SRS=EPSG%3A4326&REQUEST=GetMap&VERSION=1.3.0&SERVICE=WMS&scaleMethod=accurate&DPI=300&TRANSPARENT=true but i'm not sure

0

If you turn GeoServer logging upto GeoServer Developer (under the global settings page) you will see the parameters and any errors in the log file (usually in $DATA_DIR/logs/geoserver.log).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.