0

So, there isn't much information out there: https://docs.geoserver.org/stable/en/user/styling/ysld/reference/transforms.html#point-stacker

And I have successfully used this doc to create a simply style that stacks soil sample points on my map (Geoserver for Boundless Suite).

What I have been given now is dataset with multiple types of features where I need to use the filter: ${entity_feature_here = 'Example'} multiple tikes to have each of the (10+) features render on the map. When I do this, it obviously looks cluttered. What I can't figure out is how to use Point Stacker to cluster each of these points until they are zoomed in. When I do try, all my data seems to vanish.

name: YSLD_Point_Staclk
feature-styles:
- name: PointStacker
  transform:
    name: vec:PointStacker
    params:
      cellSize: 64
  rules:
  - name: 'Example 1'
    filter: ${entity_feature_here = 'Example1'}
    title: Example 1
    scale: [min, max]
    symbolizers:
    - point:
        size: 10
        symbols:
        - mark:
            shape: circle
            fill-color: #some color
  - name: 'Example 2'
    filter: ${entity_feature_here = 'Example2'}
    title: Example 2
    scale: [min, max]
    symbolizers:
    - point:
        size: 10
        symbols:
        - mark:
            shape: circle
            fill-color: #some color
  - name: 'Example 3'
    filter: ${entity_feature_here = 'Example3}
    title: No Plant Area
    scale: [min, max]
    symbolizers:
    - point:
        size: 10
        symbols:
        - mark:
            shape: square
            fill-color: #some color

I have tried it with and with setting the [min,max] and I have tried getting rid of the scale all together as is shown in the example in the Geoserver doc. Neither has worked, my data just disappears on the map.

  • Probably unrelated, or just an error while you tried to clean up the code, but filter: ${entity_feature_here = 'Example3} isn't right. – BradHards May 25 at 8:00
  • It works though, and shows properly in the legend and the Geoserver suite application. Might that be a reason that the point stacker isn't working? – Rad465 May 28 at 12:55
  • its not closed correctly so anything is possible. – BradHards Jun 3 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.