I am the owner/administrator of an arcgis.com web map containing feature points with pop-ups. How do I disable the editing option from the pop-up window? (see image below)

enter image description here

I unchecked attribute editing in the Configure pane (below), but no success.

enter image description here

I couldn't find an answer in the ArcGIS Online help pages...


I finally found ESRI help at https://doc.arcgis.com/en/arcgis-online/create-maps/disable-editing.htm

Here are the pertinent instructions from that web page:

  1. Verify that you are signed in and open the map in Map Viewer.
  2. Click Details and click Contents.
  3. Browse to the editable feature layer, click the More Options button More Options, and click Disable Editing.

But when I follow these steps, there's no Disable Editing option:

enter image description here

I'm still unable to disable the editing option...


Following Colin Lang's kind input (below)...

Apparently I don't have any Feature Layers. What I have are Web Maps containing layers that I downloaded from my local computer (as zipped shapefiles) to the web map I was creating in Arcgis.com, as shown here:

enter image description here

When I filter for Feature Layers, as Colin suggests, nothing is returned:

enter image description here

In summary, I'm still stuck with the original problem: How to disable the edit option in my web maps and web applications?

  • "Apparently I don't have any Feature Layers. What I have are Web Maps containing layers that I downloaded from my local computer (as zipped shapefiles)" When you add a layer from a file from within a web map, it is added as a Hosted Feature layer in your contents. Maybe, you are not seeing it because from your screenshots you are searching inside the CDLT folder. Change to All my Content and search again.Also, If you open the details of the web map from the content page, you should see the layers inside that map. From the same page, you should be able to access those layers and their settings.
    – umbe1987
    Oct 18, 2019 at 10:21

3 Answers 3


First off, be aware that Chrome does not work reliably for this, you are more likely to have it work in Internet Explorer

  • On the ArcGIS Online window, at the top you have a menu bar with Home, Gallery, Map, Scene Groups, Content, Organization... click Content
  • In the list of your content that pops up, you can find your hosted Feature Layer. Click it to see it's properties. If you have a lot of content that you have updated you can use the filters at the left to narrow it down to layers enter image description here
  • Again you have a menu near the top, on a blue bar - Overview, Data, Visualization, Usage, Settings. Click on Settings. enter image description here
  • Halfway down the page under Feature Layer (hosted) there is an Editing section. Uncheck the checkbox that says Enable Editing.
  • Thanks Colin, but I don't have any Feature Layers. I've modified my question accordingly.
    – Stu Smith
    Oct 17, 2019 at 18:36

Well, after 2+ months I finally stumbled across an answer. The Edit button, as shown in my OP, apparently makes its appearance because I am the owner of the account. When I log out of ArcGIS.com and then view my webmap's url, the Edit button does not appear.

This is an acceptable solution because it will prevent viewers from modifying my project. However, I was never able to turn off the edit from Settings or Content, as Colin Lang, umbe1987 and Son of a Beach reported. Puzzling, but thanks nevertheless to all of them for their support and input!

  • I'm glad to hear you found a solution. I have no experience publishing whole maps the way you did, so I never would have figured that out.
    – Colin Lang
    Nov 15, 2019 at 13:31

You need to disable editing using the settings of which ever feature service the map is sourcing that layer from.

If the feature service is hosted on ArcGIS Online, then this is done in the 'Settings' view of that feature service's details. In ArcGIS Online, find the feature service (not the map) in the Contents, then click on its name to see its overview, then click on the 'Settings' tab for that feature service. There are a few settings there related to editing data.

If the feature service is published to an ArcGIS Server, then this can be done by disabling the 'Update' section of the 'Feature Access' settings under the 'Capabilities' part of the settings while publishing or re-publishing the service (in ArcMap or ArcGIS Pro). Or after publishing, in the 'Feature Access' settings for that service on the ArcGIS Server Manager.

(Note that if you need the map to be available in the Collector app for mobile devices, you do need to have at least one feature service that is editable. However, for viewing the map in a web browser, this is not required.)

  • Where in arcgis.com do I find the "...feature service settings"? I've searched for settings in my Content page, the web map's description page, the web map's viewer page (including the Details > About and Details > Content pages), the More Options (...) dropdown within the point layer TOC... nothing regarding disabling editing. Yikes!
    – Stu Smith
    Aug 20, 2019 at 18:10
  • These settings are not part of the web map. They are part of one of the feature service(s) that supplies data consumed by the web map. So firstly, you'll need to identify which feature service that layer is coming from. Then find that feature service in your Contents. Then click on it, then click on its 'Settings'. I'll edit the answer to make this a little clearer. Aug 20, 2019 at 23:16
  • Thanks for your efforts, but I still don't follow. My layer was uploaded to ArcGIS.com, so I assume that it is a "... feature service ,,, hosted on ArcGIS Online..." When you say to "... find the feature service (not the map) in the Contents.." which web page are you talking about? Any chance you could include screen shots? That would really help!
    – Stu Smith
    Oct 11, 2019 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.