1

We have a system that is using the GDAL C# wrappers to talk to a WMS server. This all works ok when using HTTP, but if we try and connect to the same server using HTTPS then the call to GDAL. Open fails and the message "https not supported or disabled in libCurl" is output in the debug log. The HTTPS connection works OK with applications.

Looking online seems to indicate that libcurl doesn't like URLs with single quotes or spaces in them, but the URL we pass to GDAL has double-quotes.

It seems an obvious thing that GDAL would support HTTPS connections to WMS servers (or it does to me) so has anyone got this functionality working before, and if so, what's the secret?

We are using GDAL 1.11.0 and libCurl 7.18.

3

Tried the following

gdalinfo /vsicurl/https://labs.webgeodatavore.com/partage/S2A_MSIL1C_20170102T111442_N0204_R137_T30TXT_20170102T111441_TCI_no_ovr_strip.tif

and "it works" on my computer (Ubuntu 18.04), so clearly and environment issue (Dotnet level or more probably libcurl dll). You may try using this HTTPS URL to see if it changes from the behaviour on your computer https://labs.webgeodatavore.com/partage/S2A_MSIL1C_20170102T111442_N0204_R137_T30TXT_20170102T111441_TCI_no_ovr_strip.tif

Did you also see if curl-config --protocols contains HTTPS? If not, the problem is that you are using GDAL compiled with a CURL without HTTPS support. You need to recompile CURL with the right flag, then recompile GDAL against this CURL.

| improve this answer | |
  • Thanks, looks like I need to update our libCurl, didn't realise it was so out of date. – DCB Aug 11 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.