2

There are some similar question here, but nothing worked for me. So I have a database that has the ending .mdb which to my knowledge is some kind of Microsoft access database. But I also tried it with a test-database that has the standard .accdb-ending and did not manage to make it work.

I did the following: I clicked on Layer --> addd Layer --> add Vector Layer. Then I select database and type=ODBC and opening the connection dialog this appears:

enter image description here

And I'm not really sure what to enter here. I tried several thigs and none of them did work for me. So basically I guessed that I can name it as I want to name it. And the most important part is the Database-field. However, when I put the path to the database in there I always get the error:

Connection failed - Check settings and try again.

Extended error information:
Unable to initialize ODBC connection to DSN for C
3

You are half way there. In windows you will need to setup the ODBC connection to the database file though windows built in odbc manager. If it's an access database you may need to install the free ms access database engine. If you have ms office it might already be installed. Once you have done that the connection should work in qgis.

  • thanks a lot!! Do you know if there is any way to do this under linux as well? – Lenn Nov 29 '20 at 13:34
  • 1
    Not a big linux user but have a look here: cdn.cdata.com/help/DCC/odbc – Christian Leidersdorff Nov 29 '20 at 13:52
  • thanks a lot:) really appreciated – Lenn Nov 29 '20 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.