I have been working on a lidar processing workflow using SAGA-GIS. I determined my workflow on a single tile in the SAGA GUI and now I need to batch the operations on 100 more tiles. I wrote a batch file to call the SAGA Command Line to run all the las files in a folder.

I noticed, though, that the out DSM created by the command line process looks much more blurred and interpolated than the DSM I created in the GUI for the same tile. Then, I started to investigate, so I started running each individual process of my workflow in the GUI and in the command line with the same data.

The very first step is to import the LAS file. In the GUI, this doesn't save to a .spc file, it just seems to do it in memory. With the command line, it will save a .spc file from the LAS file. These two files are different:

Pictures of Results and Min/Max Values

The picture in the upper left is the point cloud created when I imported the LAS file in the SAGA GUI. Notice the values circled in the lower left image. Those are the Min/Max values of the upper left point cloud. The picture in the upper right is the SPC file that was created when running the Import LAS module via the command line. Notice the Min/Max values circled in the bottom right.

As far as I can tell, all the parameters I used were identical. In fact, I ran the GUI version first and then right-clicked on the module to create the batch file with all the same parameters.

Can anyone help me with this? The DSM's created by the batch file are not nearly as clear as the one created by the GUI because they require more interpolation and cannot be used for identifying tree canopy.

  • Which module do you use? Can you post the history of both files? It is a mpts file which you get after saving both files.
    – johanvdw
    Commented Dec 12, 2012 at 19:38

2 Answers 2


See if data is different. These number only show the color graduation. It does not show minimum or maximum value of your data. Change values that both are idendical as color range too. You can make grid from both data to and give Grid>Calculus> >Grid Difference to see if there are any differences. :D


This was another simple mistake on my part, unfortunately. The command line process I was using in a batch file was taken directly from right-clicking on the module in SAGA and creating a a batch file. The batch file had default arguments provided already and I assumed that those were the same arguments I had used when running the module in SAGA GUI.

I assumed wrong. The batch file was reclassifying based on a different attribute than the GUI process. As soon as I discovered the discrepancy and fixed it, the results were identical.

Thank you to all who provided input.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.