How do I force the label to stand out above the red lines to make the label more readable ?

Here is the sample of the image

enter image description here


It looks like you are doing this on a polygon layer.
There are some special problems with polygons (i.e. scale, other base data, edge of sheet misplaced labels)
But I use 2 or 3 three settings in maplex (I see you are using 10.1 so you now have access to that.
I prefer to have my labels always in the center and always in the polygon.
But that is not what it sounds like you are looking for.

First make sure maplex is on. (this is done in the dataframe properties)

enable maplex

Next go to the layer properties and choose the placement properties.


As I said I use the place label at fixed position, horizontal, and then choose the anchor point (eroded center always within)


But if you want the label directly on the outline choose the option closest point on polygon outline. and the instead of regular placement you can try the boundary placement.


And tell it not to overrun (oops I left mine checked, Uncheck yours).


Then I ussually use the do not drop option (that is just what I call it) "Never Remove place overlapping makes sure there is not anything that will cause the label to not be placed.

place overlapping
Just find what works for you.

|improve this answer|||||

One very handy way to have full control of the labels is to convert them to annotation. Right click on the layer > Convert Labels to Annotation... > Store Annotation In the Map > Convert. From there, all you have to do is select the label and drag it to wherever you like.

enter image description here

|improve this answer|||||

Bingo ! I got it to make the Font Size reduce without having to change the Font Size down. Here is what you can do:

You can make the label reduce its size to "fit" inside the polygon. Here is what I did:

1) enter image description here

2) Then right click on the layer you wish to perform reduce font size:

enter image description here

3) Hit the Layer Properties and then go to Other Options:

enter image description here

4) When you are in the Placement Properties, Go to the Fitting Strategy and enable the Reduce Font Size.

enter image description here

5) Finally, when you are in the Label Reducation, Change the pts in the Font Size Reduction.

enter image description here

|improve this answer|||||
  • I +1-ed @Aaron's answer because it seemed to answer your specific question. – PolyGeo Aug 23 '13 at 4:14
  • Too much work for me with limit time. – PROBERT Aug 23 '13 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.