2

I try to create an NDVI from Landsat and ASTER satellite images using Erdas Imagine. In Erdas, the satellite images have a nodata value of 0.

After creating an NDVI, the nodata value is still 0, but obviously there are also file pixels with the value 0 now (NDVI ranges from -1 to +1). So if I reset the NoData value to 0 (it is not done automatically), some pixels in my raster are missing since they are now classified as "nodata" 

Any suggestions?

1

I have found a workaround, but I hope there are better options. Before creating the NDVI, use Spatial Analyst/ IsNull tool with the satellite image to create a raster with two classes: data (=0), nodata (=1). Then create the NDVI and use the tool Spatial Analyst/ Con with the data/ nodata raster created before to change the nodata value to a number other than zero.

explanation in German: http://help.arcgis.com/de/arcgisdesktop/10.0/help/index.html#//009z000000ms000000

This works, but there must be better options!

0

What kind of version are you using ERDAS ? I worked on ASTER and performed NDVI from it and from what I see that ERDAS automatically sets its as BANDS 2 as red and 3 as Near Infrared and selected the SPOT XS/XI as the sensor because it has the function that you wanted and the output set to float single and should be able to produce with -1 min and +1 max result. BTW, I use ERDAS 2013 most of the ASTER that worked and one of them had a problem so I use ENVI and corrected it from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.