2

There is a problem on my system when starting QGIS. I get this error. I am running openSuse Tumbleweed 64bit and openSuse 12.3 64bit. Same problem on both systems.

Couldn't load PyQGIS. Python support will be disabled.

Traceback (most recent call last): File "", line 1, in RuntimeError: the sip module implements API v10.0 but the qgis.core module requires API v9.2

Python version: 2.7.3 (default, Apr 14 2012, 08:58:41) [GCC]

QGIS version: 1.8.0-Lisboa 'Lisboa', exported

Python path: ['/usr/share/qgis/python', '/home/evert/.qgis//python', '/home/evert/.qgis//python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python27.zip', '/usr/lib64/python2.7', '/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', '/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', '/usr/lib64/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/FontTools', '/usr/lib64/python2.7/site-packages/PIL', '/usr/local/lib64/python2.7/site-packages', '/usr/local/lib/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/gtk-2.0', '/usr/lib/python2.7/site-packages', '/usr/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info', '/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode']

The problem would seem to be the API version implemented in the sip module versus the API version implemented in the qgis.core.

How do I go about fixing the problem once and for all, as it has been a recurring problem on various occasions over the years.

My apologies if this question has been asked and answered here already. Did do a search but could not find this specific problem.

                       ------Edit------------

Used Yast to install Qgis, Grass ect, after adding the required repo's.

<URL: http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.3/
Category: YUM>

<URL: http://download.opensuse.org/repositories/Application:/Geo/openSUSE_12.3/
Category: YUM>

There is listed in the Geo repo develepment versions of both Qgis 2 and Grass 7. I have not installed them at any time on either system.

  • how did you install QGIS? Which sources did you use? The new api was introduced for QGIS dev and not for QGIS 1.8 stable. – Curlew Aug 6 '13 at 22:08
1

I ran into the same error with Opensuse 12.3 yesterday, except that API v9.0 and 9.1 are available, but v9.2 required. Looks like a packaging bug.

The available qgis2 package (QGIS 1.9.0 Master) delivers the same error message.

With the final QGIS 2.0 being released soon, there will be not much hope of getting the old rpm's repaired.

If you want to protect an installed package you can use one of these:

sudo apt-mark hold
    rug* lock-add
    smart flag --set lock
    zypper addlock 

But I don't have experience with that (yet).


EDIT

The problem with python sip 4.15 might be reported and solved here:

http://hub.qgis.org/issues/8507

Now we have to wait for new packages...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.