There is a problem on my system when starting QGIS. I get this error. I am running openSuse Tumbleweed 64bit and openSuse 12.3 64bit. Same problem on both systems.
Couldn't load PyQGIS. Python support will be disabled.
Traceback (most recent call last): File "", line 1, in RuntimeError: the sip module implements API v10.0 but the qgis.core module requires API v9.2
Python version: 2.7.3 (default, Apr 14 2012, 08:58:41) [GCC]
QGIS version: 1.8.0-Lisboa 'Lisboa', exported
Python path: ['/usr/share/qgis/python', '/home/evert/.qgis//python', '/home/evert/.qgis//python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python27.zip', '/usr/lib64/python2.7', '/usr/lib64/python2.7/plat-linux2', '/usr/lib64/python2.7/lib-tk', '/usr/lib64/python2.7/lib-old', '/usr/lib64/python2.7/lib-dynload', '/usr/lib64/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/FontTools', '/usr/lib64/python2.7/site-packages/PIL', '/usr/local/lib64/python2.7/site-packages', '/usr/local/lib/python2.7/site-packages', '/usr/lib64/python2.7/site-packages/gtk-2.0', '/usr/lib/python2.7/site-packages', '/usr/lib/python2.7/site-packages/setuptools-0.6c11-py2.7.egg-info', '/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode']
The problem would seem to be the API version implemented in the sip module versus the API version implemented in the qgis.core.
How do I go about fixing the problem once and for all, as it has been a recurring problem on various occasions over the years.
My apologies if this question has been asked and answered here already. Did do a search but could not find this specific problem.
Used Yast to install Qgis, Grass ect, after adding the required repo's.
<URL: http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_12.3/ Category: YUM> <URL: http://download.opensuse.org/repositories/Application:/Geo/openSUSE_12.3/ Category: YUM>
There is listed in the Geo repo develepment versions of both Qgis 2 and Grass 7. I have not installed them at any time on either system.