3

I am new to QGIS (just installed QGIS 2.0.1) and am having problems running any spatial analysis tools. I followed the instructions on how to call GRASS tools into QGIS, but when I try to run the r.walk tool I get an error.

Raster map is in different zone (14) than current region (0)

Unable to open raster map

Raster map is in different zone (14) than current region (0)

Unable to open raster map

Unable to open raster map

I used the r.region tool to find try to set the region to the raster and also checked all the layers to make sure they had the same CRS which they did. I created the slope data from my DEM in GRASS, so i know that they are the same, and the vector data already had the same CRS. I have tried a number of different approaches from what I have found on forums, but none have solved my issue. I have no idea how to proceed. Any suggestions?

  • 2
    It should be the g.region tool since the r.region tool is used to change metadata of a map. Maybe a typo? – markusN Oct 1 '13 at 19:56
  • Are you working on a raster map loaded from within/in QGIS? Could you please verify that the extent of the "current" region (for GRASS GIS) is set so as to include the extent of your raster map? – Nikos Alexandris Oct 13 '13 at 10:31
1

I would not recommend manually editing the cellhd files. That will surely lead to trouble down the line. When using GRASS (unlike some other, less strict GIS software) you must set the correct coordinate system and region before creating or importing any data. That's probably why you had trouble displaying your rasters. If you have data layers with no projection information, and you import them into GRASS, then you will not be able to compare or analyze against any other, correctly projected layers.

I think you should proceed as follows:

  1. First determine what the correct CRS is for his original rasters.
  2. Then create a new LOCATION and MAPSET using that CRS
  3. and only then import the rasters into that LOCATION/MAPSET
0

I have had the same problem working directly with GRASS. I imported some grid files without projection information before setting the default zone and projection to GRASS. These rasters files received the zone 0. After changing the default zone and projection with g.proj those rasters remained in zone 0. I think it is not possible to change the zone of the files using any of the available tools. Each raster has a corresponding metadata file in "mapset"/cellhd which is an ASCII file. I have edited these metadata files with a plain text editor and it seems it works.

  • 1
    Welcome to GIS SE! You'll probably notice that I removed your signature from your Answer which is because every post you make is already “signed” with your standard user card, which links directly back to your user page. – PolyGeo Nov 12 '13 at 9:11
0

In QGIS 2.8, open the GRASS tool g.region.multiple.raster. Even if you only want to set the region to one raster, you can use this took to solve the "Raster map is in different zone" problem. Just type the name of your raster(s). Make sure the rasters are properly imported into the mapset first and that the location is consistent with the projection of the raster.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.