0

I followed this tutorial to set up Postgresql 9.1 and PostGIS 2 on my Ubuntu Server 12.04. I also installed pgAdmin III on my Windows 7 client. I set up a database landarch and user chadmwade, granting all privleges. I am able to connect to the postgres and the landarch databases with pgAdmin III and in QGIS.

I am getting the following error when attempting up add this shp file to the database. Is someone able to guide me in addressing this error? I haven't had much luck with Google.

this

  • Have you tried DB Manager instead of SPIT? I thought SPIT was deprecated anyway. – underdark Nov 5 '13 at 17:23
  • 1
    @underdark: I did now and it worked. Thanks. – LandArch Nov 5 '13 at 21:52
1

Use the new DB Manager it is "part of QGIS core and intends to replace the SPIT Plugin and additionally to integrate all other database formats supported by QGIS in one user interface. "

Amongst other features it has a nice "Import layer/file" button:

enter image description here

1

Probably your geometry column is defined as "multipolygon" and your shapefile maybe has only geometry type "polygon".

In your insert-statement use st_multi(your_geometry_column), where instead of your_geometry_column you have to enter the name of your geometry column.

  • The shp files do not have a existing geometry column form what I can see in the attribute tables. Also I am doing this through the GUI for the SPIT plugin associated with QGIS 2.0. – LandArch Nov 5 '13 at 17:15
  • @LandArch - In general, the geometry column for an ESRI Shapefile is named Shape, so that is what you would enter. – Get Spatial Nov 5 '13 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.