I'm trying to publish data on GeoServer.

I'm using Postgres/PostGIS and I've used osm2pgsql to load the data into the database.

I've configured a store correctly (I can see the tables from the database listed when I add a new layer and choose the store).

However when I go to add a new layer, what I see is different to the manual at geoserver (refer Publishing a PostGIS Table). The point that is different is the "Create a Layer" section, step 3 and 4. On step 3 it states the following:

From the New Layer chooser drop-down menu, select cite:nyc_buidings.

I choose the data store and then get the list of layer names in the form:

enter image description here

The above screen shot is different to the doco for point 4. The doco for point 4 is as follows:

enter image description here

While I expect the names to be different, the problem is that none of the names are selectable. The only text that is selectable is Publish. It's slightly confusing, partly because I've not been able to find any example specific to what I'm trying to do, so I've had a lot of missteps along the way and have learnt the hard way not to make any presumptions.

My question is: is the Publish action against each table the same as the selectable text in the doco?

My concern is that I don't want to accidentally publish all the data in a table.


In answer to my question, the answer is yes. The publish link is the same as what is currently shown in the documentation.

When I click publish I get similar options to what is shown in the documentation, albeit with a lot more options. I was able to successfully publish the layer for the PostGIS by guessing on the field that I needed to populate from the existing doco.

Apparently the documentation at GeoServer hasn't been updated to reflect changes with screens.

I also had to add a style that supported the data from OSM. I found a reference to one that supports the roads at http://blog.geoserver.org/2009/01/30/geoserver-and-openstreetmap/, which was very useful (refer to the styling section in the blog post).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.