3

I am using Geoserver 2.5 on ubuntu and am trying to cache a layer that has it styles in workspaces.

When I try to start the cache with seed/truncate nothing happens and I get things like this in the logs:

2014-04-07 10:56:03,939 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - Converted URL to lowercase, from: '/gwc/rest/seed/wis_gent:maaiveld'; to: '/gwc/rest/seed/wis_gent:maaiveld'  and httpMethod= GET
2014-04-07 10:56:03,939 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - ~~~~~~~~~~ antPath= /** methodList= [GET]
2014-04-07 10:56:03,939 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - Candidate is: '/gwc/rest/seed/wis_gent:maaiveld'; antPath is /**; matchedPath=true; matchedMethods=true
2014-04-07 10:56:03,939 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - returning ADMIN
2014-04-07 10:56:03,940 TRACE [org.geoserver.ows.OWSHandlerMapping] - No handler mapping found for [/gwc/rest/seed/wis_gent:maaiveld]
2014-04-07 10:56:03,941 DEBUG [org.geoserver.filters] - Compressing output for mimetype: text/html;charset=ISO-8859-1
2014-04-07 10:56:03,942 DEBUG [org.geoserver.security.filter.GeoServerSecurityContextPersistenceFilter$1] - SecurityContextHolder now cleared, as request processing completed
2014-04-07 10:56:04,028 TRACE [org.geoserver.ows.OWSHandlerMapping] - No handler mapping found for [/gwc/rest/web/geowebcache_logo.png]
2014-04-07 10:56:04,029 DEBUG [org.geoserver.filters] - Not compressing output for mimetype: image/png
2014-04-07 10:56:04,034 DEBUG [org.geoserver.security.filter.GeoServerSecurityContextPersistenceFilter$1] - SecurityContextHolder now cleared, as request processing completed
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - Converted URL to lowercase, from: '/gwc/rest/seed/wis_gent:maaiveld'; to: '/gwc/rest/seed/wis_gent:maaiveld'  and httpMethod= POST
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - ~~~~~~~~~~ antPath= /** methodList= [GET]
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - Candidate is: '/gwc/rest/seed/wis_gent:maaiveld'; antPath is /**; matchedPath=true; matchedMethods=false
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - ~~~~~~~~~~ antPath= /** methodList= [POST, DELETE, PUT]
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - Candidate is: '/gwc/rest/seed/wis_gent:maaiveld'; antPath is /**; matchedPath=true; matchedMethods=true
2014-04-07 10:56:05,610 DEBUG [org.geoserver.security.RESTfulPathBasedFilterInvocationDefinitionMap] - returning ADMIN
2014-04-07 10:56:05,611 TRACE [org.geoserver.ows.OWSHandlerMapping] - No handler mapping found for [/gwc/rest/seed/wis_gent:maaiveld]
2014-04-07 10:56:05,613 DEBUG [org.geoserver.gwc.layer] - --> GWC Seeder Thread-6 submitting getMap request for meta grid location [0, 0, 0] on org.geoserver.gwc.layer.GeoServerMetaTile@27897fc
2014-04-07 10:56:05,614 INFO [org.geoserver.wms] - 
Request: getServiceInfo
2014-04-07 10:56:05,616 DEBUG [org.geoserver.ows] - Getting layers and styles from LAYERS and STYLES
2014-04-07 10:56:05,616 ERROR [org.geoserver.ows] - 
org.geoserver.platform.ServiceException: No such style: wis_bestemming
    at org.geoserver.wms.map.GetMapKvpRequestReader.parseStyles(GetMapKvpRequestReader.java:1386)
    at org.geoserver.wms.map.GetMapKvpRequestReader.read(GetMapKvpRequestReader.java:318)
    at org.geoserver.wms.map.GetMapKvpRequestReader.read(GetMapKvpRequestReader.java:80)
    at org.geoserver.ows.Dispatcher.parseRequestKVP(Dispatcher.java:1412)
    at org.geoserver.ows.Dispatcher.dispatch(Dispatcher.java:622)
    at org.geoserver.ows.Dispatcher.handleRequestInternal(Dispatcher.java:263)
    at org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
    at org.geoserver.gwc.GWC.dispatchOwsRequest(GWC.java:1162)
    at org.geoserver.gwc.layer.GeoServerTileLayer.dispatchGetMap(GeoServerTileLayer.java:572)
    at org.geoserver.gwc.layer.GeoServerTileLayer.getMetatilingReponse(GeoServerTileLayer.java:517)
    at org.geoserver.gwc.layer.GeoServerTileLayer.seedTile(GeoServerTileLayer.java:711)
    at org.geowebcache.seed.SeedTask.doActionInternal(SeedTask.java:136)
    at org.geowebcache.seed.GWCTask.doAction(GWCTask.java:76)
    at org.geowebcache.seed.MTSeeder.call(MTSeeder.java:36)
    at org.geowebcache.seed.MTSeeder.call(MTSeeder.java:25)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:744)
2014-04-07 10:56:05,617 ERROR [org.geowebcache.seed.MTSeeder] - Problem communicating with GeoServer
org.geowebcache.GeoWebCacheException: Problem communicating with GeoServer
    at org.geoserver.gwc.layer.GeoServerTileLayer.getMetatilingReponse(GeoServerTileLayer.java:522)
    at org.geoserver.gwc.layer.GeoServerTileLayer.seedTile(GeoServerTileLayer.java:711)
    at org.geowebcache.seed.SeedTask.doActionInternal(SeedTask.java:136)
    at org.geowebcache.seed.GWCTask.doAction(GWCTask.java:76)
    at org.geowebcache.seed.MTSeeder.call(MTSeeder.java:36)
    at org.geowebcache.seed.MTSeeder.call(MTSeeder.java:25)
    at java.util.concurrent.FutureTask.run(FutureTask.java:262)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:744)
Caused by: java.lang.IllegalStateException: Expected: RenderedImageMap, got null
    at org.geoserver.gwc.layer.GeoServerTileLayer.dispatchGetMap(GeoServerTileLayer.java:575)
    at org.geoserver.gwc.layer.GeoServerTileLayer.getMetatilingReponse(GeoServerTileLayer.java:517)
    ... 9 more

Using a style without a workspace works great. Does anyone have any idea what could be wrong and if I can use a style in the workspace?

  • what sld version are you using? – Carl Carlson Apr 9 '14 at 15:23
3

As you can see here it is a known issue.

There is bug submitted to GWC GitHub: https://github.com/GeoWebCache/geowebcache/issues/232

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.