2

I am trying to use las2las from libLAS on Ubuntu 14.04 entering the following code into the terminal:

las2las --input merged.las --output ground.las --keep-class 2

This outputs a LAS file which has bounds -214.XX, -214.XX,-214.XX,-214.XX. Just to make sure the merged.las file was good, I was able to open it up and view it in ArcGIS 10.2.2 on a Windows 7 machine. I've also tried a variant where --input was changed to -i and likewise for --output, but got similar results.

Has anyone else encountered this problem? Is there something wrong in my code?

EDIT: After more testing, I found out my real issue is lasmerge. I have tried the following two lines of code

ls *.las > lidardata.txt
lasmerge -i lidardata.txt -o indianhill.las

I have also tried:

lasmerge -i 640.las -i 641.las -i 686.las -i 687.las -o indiantwo.las

Both of them result in incorrect bounds. I have also tried the -verbose flag, which the help/manual suggest lasmerge should have. But, I get an error saying that it is not a command.

0
2

I believe you have a typo inside your code. Instead of class, it should be classes. See here (manpages.ubuntu.com).

Try this:

las2las --input merged.las --output ground.las --keep-classes 2
1
  • Andre, I have upvoted you because you did correctly answer the question. However, I have updated my question noting that the issue that I have is apparently due to lasmerge and not las2las. Do you happen to have any ideas what the issue with lasmerge might be?
    – jwx
    Jun 10 '14 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.