1

I am experiencing a problem installing QGIS 2.4 Chugiak on Windows 8.1, resulting in a error loading Grass. This may be a problem only affecting certain installations, I'm not sure. I am a noob on QGIS and not so hot on IT.

The installer QGIS-OSGeo4W-2.4.0-1-Setup-x86_64.exe does not report any errors, but when QGIS is launched a dialogue box reports that there is an error in finding the Grass installation and asking for the folder where this is located. Pointing to the folder results in it being unrecognised by the dialogue box, which asks the same questions again.

This appears to have happened to others in the past (QGIS is not able to find GRASS. Choose the path of installation folder of GRASS) and occurs due to either of both of long path names not being recognised (or being correctly resolved to short names)and/or spaces in the file names.

  • 1
    Hi, you can answer your own question (and accept it as correct). That way it will be easier for future readers to find it. If you think it is a bug in QGIS / the installer, please file a bug so it can be taken care of. Thank you in advance. – Matthias Kuhn Jul 26 '14 at 10:32
  • 1
    Agreed - can you edit the answer part of this out into an answer and then perhaps elaborate a little on what the original question was, please? For now I'll just take the "Solved" part out of the title and turn that into a question. – PolyGeo Jul 26 '14 at 10:40
  • Thanks for the suggestion about board etiquette. Happy to do so. Hope the result is OK. – user21658 Jul 27 '14 at 13:17
1

This problem was resolved by editing the install path to remove all spaces.

I used d:\program\qgischugiak\, so this implies that perhaps the name used does not have to comply with 8.3 filename convention and is interpreted correctly by the OS.

This worked perfectly, for such a simple fix.

This fix came from some suggestions on other sites (thanks to them) and by looking at the results of the postinstall.txt file in the root directory of the install folder which showed that the installer was failing when trying to load to folders (specifically "c:\program files\") with spaces in the title.

The issue has been reported as [QGIS Application - Bug report #10955]

Hope it helps someone as hopeless as me!

-1

I have had massive issues making a clean install of QGIS and GRASS. It didn't matter which version of QGIS or GRASS, if I used the stand-alone installer or the OSGeo4 thing. Changing the path to GRASS in QGIS did not work either.

What did work:

  1. I changed the name of the QGIS folder to "C:\Program Files\QGIS3.2" (removed the space between QGIS and 3.2).
  2. Opened the file C:\Program Files\QGIS3.2\bin\qgis-bin-g7.4.1.env in Notepad and did a Find/Replace for QGIS 3.2 and replaced with QGIS3.2.
  3. Everything seems to be fine now.

PS. Why on earth do you have to hack the installation to make it work!?!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.